PlaneConstraint acts weirdly

Hello there,

I recently discovered the new instance: PlaneConstraint

I wanted to use it and so, as nearly all constraints: you have to use Attachment instances to make it properly work.

I tried to make it work and rotate the 2 attachments (and also change the WorldPrimaryAxis and WorldSecundaryAxis match, but it didn’t change anything). When setting up the constraint with 2 cylinders with an orientation of 0, 90, 0, and new Attachment that are parented to both cylinders, by keeping default WorldPrimaryAxis and WorldSecundaryAxis, it works.

But, the plan goes towards the Z axis, while I want it to go towards the X axis.


I tried to rotate attachments, parts, and so much things, and it changes the orientation of the plan, but an error message is being displayed, telling me that my plan aren’t the same and aligned ; and so the physics engine will have to replace everything correctly to make it work.

I still don’t understand why it doesn’t work, and I’m a bit despaired…

What I need is a kind of tutorial… Roblox didn’t provide anything (did they?) and I’m really lost…

If you have anything to ask, feel free to do so !


I didn’t have enough will to share screens of gifs, because I just passed 1 hour on Studio to make it work and I’m really fed up about it

Thanks for having read,

Varonex_0

2 Likes