Play Solo Immediately Freezes on MacOS

When clicking on Play Solo in Studio it will freeze and I have to force quit Roblox Studio. I have reinstalled Studio which didn’t affect this at all. I would expect Studio to work as it normally does when clicking Play Solo.

The bug always happens to me. Even in a blank baseplate.


  1. Open a baseplate
  2. Click Play Solo
  3. Studio freezes

The bug happens on my MacBook Pro. Specs:

It is not game specific. Baseplate - Roblox

Here’s a video of the bug.

The bug began happening about a week or two ago. I remember seeing at about the same time it started happening a thread about APS being forced, but I think I already had APS enabled.

Other parts of Studio work as expected and the Roblox Player works fine too. As I previously mentioned a reinstall also didn’t fix this.

Are you sure this is the case?
I’m on Mac High Sierra (I still didn’t software update) and everything performs fine.
Animated GIF:

My MacBook Specs:

1 Like

Just tried again and it still freezes. I’ll try uninstalling some apps I’ve installed recently and see if that affects it.

Just removed some unused apps that I installed around the same time this began happening and did a restart. Studio still freezes when clicking Play Solo. Something different is that when I opened Studio it wanted me to login again which worked fine.

To rule out the possibility of a setting being messed up I reset all settings back to their default value and it still freezes.

Edit: Just reinstalled and it still freezes. I might try reinstalling MacOS sometime.

Edit: I changed my graphics mode to both Metal and OpenGL and on both it freezes. Same for automatic graphics.

No idea what I did but this seems to be fixed now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.