Player appears on horse on one client but not another

I am experiencing a bug with my horse system where the players position isn’t consistent on all clients. While Player1 is riding around on a horse, occasionally Player1 will appear to fall off the horse on other players’ clients. However, according to Player1, it looks like they are still on the horse. (If you’re confused, I provided screenshots below)

The horse’s movement is controlled by a LocalScript, which I currently believe might be the cause of the issue. I tried using a remote event to move the horse on the server, except the code began to get very messy and I wasn’t able to make the horse the move the way I wanted.

Why is the player falling out of the horse on one client and not the other, and how do I fix it?
If anybody has found a solution to a problem similar to this, I would appreciate knowing how you solved it.

How it appears to the player riding the horse

How it appears to other players

This bug will ruin my whole game, so all help/ideas are greatly appreciated.

This is why your code isn’t working as intended. You have to use some sort of remote event to communicate to the other clients what they are supposed to see.

So your saying use :FireAllClients()?

I feel like an event fired with FireAllClients would work, yes. (im not 100% sure im pretty inexperienced with developing but ive used events b4)

The problem is that the player isn’t supposed to fly out of the horse. Other clients would see the same thing, but what they would see is a player flung out of a horse. So I suppose the real issue would be keeping the player in the horse?

Ah, yes, sorry. I misread the question.
Yes, that may be the issue, if that is what is causing the horse to vanish.
Are there any obvious errors in your code? (e.g. an accidental typo, a loop not ending, etc)
Maybe try welding the player to the horse on the server?
I’m sorry; my solutions sound (and probably are) stupid and are most likely ineffective. I’m more of a builder/modeler, yet for some reason the only tag I have is Programmer.

I hope you can find some help soon.

These are good suggestions. I did try welding the horse to the seat, however nothing seemed to change. No obvious errors in the code, I guess I should try welding the player to the seat again?

I was able to solve the problem using another weld, thanks everyone for helping

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.