Plugin script is still running after I overwrite the local plugin file (in Roblox Studio)

Hi Guys,

I hope someone can help.
I’m developing a plugin and I have experienced that at least one previous script is still running after I change the script and re-save as local plugin. So 2 or more copies are running parallel, and the invalid (old) ones spams errors as many objects are missing in their environment.

It is quite annoying and I haven’t find any way to close/destroy/delete etc. a plugin object when I don’t need it an more.

As I understand it could be automatically handled by the Studio, but it seems it doesn’t do it in the way I imagined.

(I tried many ways, like :Destroy the previous plugingui / plugin object at plugin start, but it doesn’t help).

May you know any topic about it, just drop a link to it!
I haven’t found any solution or even anything about the problem itself.

1 Like

Yeah, it’s incredibly annoying :confused: my solution is to close the place and open it again every time I really need the old plugin instances to go away so I can actually use the Output window.

This reminds me, back in the day I used to use HotSwap v2.0.2 - Roblox for plugin dev, no idea if it still works but I’ll check it out and report back when I have time.

1 Like

Thank you for the feedback, so I’m not alone with the problem. :frowning:
I haven’t tried to close the place and open again, it is a good idea as a bit faster workaround. I’ll try it.

Anyway, I’ll check out Hotswap too.

I don’t want to give up developing this plugin but I can’t continue it in this way.
+1 minute is too much for each test run.

1 Like

I get it down to a few seconds like this:

  • Ctrl+Shift+K to “Save as Local Plugin” (can be bound in settings)
  • Enter to save
  • Alt+Y to accept overwriting existing local plugin
  • Ctrl+S to save (prevents dialog when closing the place)
  • Click cross to close place
  • Click File
  • Press Alt+1 to open last place
  • Click Connect in Rojo

Tried it just now, takes about 8 seconds. Still incredibly annoying though.

1 Like

TY so much! The shortcut editor is new to me, I’ve set the ‘save as local plugin’ - this is sg new and useful to me in general! It seems there is no real solution to the core problem, so I marked your workaround as a solution, ty again!

2 Likes