Plugin widget GUI dispaying outside of screen


#1

So for some reason, one of my plugin widgets has began showing up outside the bounds of my screen (top left corner). The contents of the widget are still visible, but not the header, meaning I can’t move, close or otherwise modify the widget itself. If the widget was big enough, it could also potentially obscure important buttons.

2018-12-04_08-57-43
As you can see in this screenshot, I can still use the contents of the widget, but I can’t move it or anything.

This has only happened with this specific GUI. Reinstalling the plugin didn’t change anything, and this issue is occuring across Studio instances (so restarting doesn’t change anything either). I’m in no mood to reinstall Studio as it’s a hassle to reinstall my plugins, and I should not have to.

This issue began recently, unsure of the cause. It just happened out of the blue.

As a suggestion of fixes to this bug, if for some reason actually fixing it is too hard or whatever, just give us a hotkey to reset the position of widget windows.

Aww heck yeah, cake day!

Update: Kiansjet gave some hotkeys that managed to fix the problem. Alt+Space after focusing the broken window to open the header context menu, then press M and use the arrow keys to move it. This is still an issue though.


#2

I’ve had this and similar (sometimes the widget is outside the bounds of the screen entirely) happen occasionally in the past couple months (?) after refreshing local plugins while I’m working on them, also have no idea what causes it. I concur that the only fix is to reinstall studio


#3

It may be helpful if both of you post information about your systems. To me, it sounds like a GPU driver problem, and I haven’t experienced the problem on my GTX 1070 based system (~driver version 380).


#4

Windows 10, RTX 2070, driver version 416.94.


#5

Have you tried Ctrl+Space+M to activate the legacy move tool and dragging the plug-in widget?

Not tested


#6

That hotkey does nothing :wink:


#7

Are you using OpenGL as your renderer by any chance?

OpenGL causes a lot of problem with PluginGuis. For instance, when I have it turned on, it looks just like yours, except all of my PluginGuis are flashing rapidly on the screen, which tanks my FPS.

Could be related, otherwise I don’t know.


#8

Mine’s set to automatic, so I’m not sure which one specifically.


#9

Try setting it to D3D11.


#10

I’ve already fixed it on my end with the solution in the edited OP, but if it occurs again I’ll check it out.