Plugins cannot revert to previous version

Plugins are unable to revert to previous versions.

TEST YOUR THINGS before releasing them!

Obs somehow got deleted I am very annoyed right now

Expected behavior

Its supposed to revert my changes. I am very furious with how many bugs I am experiencing with roblox. I feel very unlucky right now.\


I am seeing this also in the console

Sorry about this. We will take a look at this issue and I’ll keep you updated on the progress.

I tried it on other plugins too and I am seeing this in output as well

1 Like

I see a console message stating “MaxAttemptsReached.” This likely is a message by the development team indicating that the maximum amount of retries on the request to 

has been reached. Its possible that for some reason roblox’s API has an issue or there are some weird privledges going on. I noticed that it stated something about me not owning premium so perhaps the API requires me to have premium to access it.

Hello, can you try reverting your plugin again in creator dashboard? We pushed a fix for the issue.

it looks like it works however I strongly suggest that you add a confirmation message. Just copy and paste what you did with reverting the version history of experiences.

It seems very easy for users to accidentally make unintended changes (and to keep track of current ones.) It could also put a lot of stress on roblox’s servers with requests being sent to easily.

Also I am noticing that some of the updates don’t have a restore next to them

It would be appropriate as well to match the buttons to be consistent too. here is what it looks like when reverting the version history of experiences:

Notice how the buttons arent outlined.

Weird loading

see how its buggy

So here is a list of things needed:

  • Remove outline
  • Fix restores not popping up for some items
  • Add a confirmation message
  • Fix the weird loading (For experiences, the messages load all at once rather than one by one)

Thanks for the feedback, I agree that the loading and button outline should be consistent.

For restoring not popping up, this means that the current version is restored from that version without the button. I think if we made it clearer that the current version is a restored version of a previous version it would also solve the confirmation message issue.

Below is what Version history looks like for Packages/Models which we can also update to Plugins.

1 Like

Maybe you shoulf allow developers to filter restore poimts through stuff like timeframe, user, change made (if applicable) etc

This is solved but I want to counter this. Bugs slip through the cracks, even with rigourous testing, humans are humans.

Its fine and dandy saying “test things”, but you can only go so far with testing before it becomes infeasible and you just ship the feature. Should obvious things like this slip through those metaphorical development cracks? Probably not, but again, it happens.

1 Like

Stop over analyzing the situaton I was mad because a bunch of stuff was going wrong at the same time. Sometimes there is immaturity and sometimes there is being pushed over the edge. Imagine you are trying to make a plugin that doesnt work due to a bug by the roblox script editor (because apparently they don’t support what you’re trying to do anymore) then you accidentally deleted all your progress then you try to revert the changes and it doesn’t work for some reason and you try reloading the page, deleting and uninstalling roblox studio, restarting your whole PC and nothing works. then you try to make a dev forum post and you realize OBS somehow got deleted etc you get the point though

This mockup is much clearer than the current page.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.