Plum's minimap - Rotating map, bordersnapping blips and more!

Hello !
It’s a really great minimap UI to use with RoRender! Great job :smiley:
However, I have some problems.
The minimap is reversed.
Like on my map, the A point is for example at the south and the B point is at the north.
On my minimap, A is at the north and B at the south.
Did you get it?
I tried to change some values in the configuration script and in the RoRender settings before rendering but it doesn’t seems to work :confused:
I’m stuck with this for 1 week.
Could you help me please? Thanks :slight_smile:

1 Like

Hello! Have you updated your minimap recently? Please update to the newest version here.
You’ll have to update your settings again.

2 Likes

I tried the new version but the minimap don’t want to show.
No error.
I put the 2 scripts in ServerScriptService.
If you have Discord, add me in friend : Certurix#9930

The minimap has to be placed in the workspace the way you get it. Take a look at how i’ve set up the minimap in the demo game.

1 Like

How I can know the map size?

UPDATE!

This minimap now supports roundness!
Change the setting [“Gui”] → [“mapCornerRoundness”] to your desired roundness (It works just like the cornerradius property of the uicorner.)

@TreR_BLX
@Certurix Tutorial below here!
Insert the model to start using the minimap.

You’ll first of all need a tag editor plugin , so you can add tags to the part, which will tell the minimap to make a blip at that location. The minimap will error, if you add a tag, which you’ve added to the bliplist, to anything that is not a part. ONLY ADD THE TAGS TO PARTS.

You’ll also need a picture of your map. This can be made with this tool by @Widgeon & @reteach.

Render the map, and then set the settings. You’ll just have to write four values down:
(Note your values will not be the same values as shown below. Only the names will be the same)
image Pixel Size X, and Pixel Size Z/Y can be different from eachother. Write both of them down!
and
image
and
image

So in this case the mapsize is would be: 100/0.5 = 200 This is because the pixel per stud is 0.5 and the pixel size is 100

The map is in this case 200x200 studs.
The mapcenter is in this case Vector3.new(0, 2, 0)

Set the Settings[“Map”] → [“size”] to the size of your map. In this case i would set the map to Vector2.new(200,200)
Set the Settings[“Map”] → [“mapCenter”] to the center of your map. In this case i would set the map center to Vector3.new(0, 2, 0)

This minimap has a lot of setting which you can tweak.
image
You access the settings by going Minimap → Settings.
This has been taken from the tutorial, which is in the topic.

4 Likes

UPDATE
I’ve chosen to revert to my old method of updating the minimap. This mean you will have to manually update to the newest version of the minimap, if it has some features you’re interested in.

This update fixes the problem, where you were unable to use the API.
If you’re not intending to use the API, then you can ignore this update.

When you’re updating to the new version, then you will have to update the settings too. This has to be done manually, because there can be added new settings to the module.

See how to set up your minimap here.

4 Likes

UPDATE

This is just a small update. This update contains some bug fixes, that has affected developers using the API. This update also changes the :Resize function making it take in a Vector2.
This update contains a fix to the “onePixel” setting making it actually reflect what one pixel on the map is in studs.

I’ve followed the instructions, set the values and the render is currently pending but whenever I test the game the map itself doesn’t show up. Instead this shows up:
image
I don’t know if this is because of the fact that the decal is pending for reviewal due to Roblox moderation or if it is actually wrongly set up, can you confirm that it is the pending fact or try to help me with setting it up correctly?

Try again now. The minimap uses decals, so the pending theory would make sense.

I added the ID I was using to a texture and it changed (to reduce the current number with 10) and I used that number instead, in this case that worked and the map showed up but its rotated wrong. It needs to be rotated 90 degrees to the right using the Y axis. Is there any setting I can change to make this happen or is it a bug?

Have you downloaded the newest version of the module? If it doesn’t help with updating, then i would guess that you’ve made a mistake when rendering the map.

1 Like

Yes I have downloaded the last version, one of the lines didn’t write on the last render so I re-rendered it and it still doesn’t work, the map starts as last time.

Something to note down is that in the scripts it says Version: 1.0.0 even though I brought it yesterday from the toolbox. Just wanted you to know.

I’ve made an update to the minimap adding a setting under [“Technical”] named [“mapRotation”]. It defaults at -180, but you can change it to what is needed for your minimap.

Update your minimap by downloading the new one, deleting the settings module from the new minimap, putting the settings from your old minimap into the new minimap, and adding a line saying:

["mapRotation"] = -180; --The amount of degrees the map has to be rotated for it to be correct.

under the [“Technical”] section

1 Like

I changed it to the correct orientation but now the positioning of it is wrong. I started messing with the part inside of the map to realize that the positioning was the issue after changing the rotation. The rotation should be good now though since its correct besides the actual position where you start.

I was wondering if it has to do with the center position since I know for sure it’s the same as the RoRenderV2 plugin said.

One note on that, if there’s a function to set where the player starts on the map and it adjusts accordingly, that’d be great but I’m not sure if setting the world center to the player’s root part’s position since I tried that.

Ok. I’ve found out what the problem is. You’re using the rorender plugin wrong. Click the “Auto configure” button before rendering your map. (The values you’ll need to write down may have changed after clicking the “Auto configure” button.)
image

I hope this helps you :slight_smile: If not, then feel free to ask for help :slight_smile:

If I use auto-configure it puts things I don’t want in the minimap in, and I take screenshot on the settings before starting to render so I don’t believe that it is the issue. Althought theoretically I can just adjust map center until the positioning is correct?