Minimap Render [RoRenderV2]

RoRender

Application | Plugin | Source Code

RoRender is project designed to create a topdown orthographic projection of your maps. The primary use case for this tool is to create minimaps in game. This is the third iteration of this tool and it may be useful to look through old posts to understand how it works.

This project has evolved to the point where a lot of the information, tutorials, and questions and answers are irrelevant to modern day usage of the tool, thus the new forum post. In this iteration a new plugin and GUI application was built for this tool.

Quick Start Tutorial
  1. Make sure that you have the Plugin installed to studio and an appropriate OSX or Windows copy of the application downloaded.
  2. Open the place you want a minimap of, launch the RoRender plugin and press the auto configure button. The purple box should be floating above the entire map now. Click Inject Scripts to load rendering scripts into the game. While in studio go to Home>GameSettings>Security and make sure allow HTTP Requests is on. (It is off by default)
  3. Launch the application and press Start Server (You must press Start Server on the application before beginning the rendering process)
  4. Go back into studio>test>clients and players and set the number of players == the number of cores your cpu has. Then press the start button to the left of the players menu. If you do not know how many cores your cpu has, you can find out by googling it
  5. Reopen the RoRender application and watch the image being rendered in the live preview box. Once it is done you can press the download image button and save your image like any other file.

For more specific configuration details you can read about the application here, here, here, and here

Caveats
  1. This plugin cannot render texture. Meaning that meshparts will most likely appear as grey blobs if they are not solidly colored.

  2. Streaming Enabled must be turned off else all the chunks that your clients have not loaded in will not be rendered.

  3. You can attempt to render too large of a map. Http request, as well as Lua, can only handle so much data so it is best to split your map into chunks if you are working with an obscenely large map

  4. You will have to delete invisible parts you do not want apart of the render or they will show up in your final image.

  5. It must be on a published game because roblox does not support turning on HTTP service on non-published places

  6. You MUST press inject scripts to apply settings from the plugin before running render program otherwise old settings will be used. (Or none at all if inject scripts was never pressed)

Featured Renders

Post your cool renders on this thread to get included on featured.


by @PhoenixSigns

by @rek_kie

by @CheetahSp33d

by @Scriptos

by @SillyMeTimbers

Render Application

This is an unsigned program with no certificates meaning that your computer will likely think that this application is a virus. You can check the source code and verify that nothing fishy is going on. To launch the application from the source code, you will need npm and electron installed.

Contributors:
@StrategicPlayZ
@Widgeon
@reteach

144 Likes

Nice! Definitely going to be coming back to this as my map changes and changes. This looks so much more user-friendly as well.

Questions/concerns/PSA’s though:

  1. More or less I think the rendering method is the same as the last one? (Where you press play and use clients)

Meaning that:

  • You should probably clarify that StreamingEnabled needs to be off. Otherwise the entire map (depending on how big it is) will not be available to clients (unless you move around so everything gets streamed in but no one wants to do that…) causing you to get incomplete renders of your map like this:

(stumped me for like an hour or two, did like 9 renders wondering what I was doing wrong :skull: )

  1. Also, the issue that would cause RoRender V1 not to work (especially for lower/medium end systems like mine) was the PlayerAdded function in the server script that was actually supposed to start the rendering. Not sure if you’ve heard about it, but PlayerAdded sometimes will not fire on game initialization if a client joins before the function is connected. For games with big maps, meaning longer load times, this will happen a lot more.

So basically, if you haven’t done it already, make sure the PlayerAdded function accounts for people who could’ve joined before the function connected:

local players = game:GetService("Players")

local function onPlayerAdded(player)
    -- code 
end

players.PlayerAdded:Connect(onPlayerAdded)

for _, player in ipairs(players:GetPlayers()) do 
    coroutine.wrap(onPlayerAdded)(player)
end 

Again though, amazing job. This plugin is extremely convenient and I’m glad to see it got updated

9 Likes

I forgot to mention that in the caveats section, it is updated now.

And I have updated the plugin to fix that issue. Thanks : )

1 Like

Wow, just wow. This project has evolved in such a good way. From glitchy Java files to this! Honestly you have done an amazing job!

1 Like

I tried it out for an underground facility map and with some adjustments, it actually covers most of the layout very nicely. Since an interior-heavy minimap is not really guaranteed to be perfect, at the very least, it’s pretty useful in making it easier to trace out a custom minimap from the generated image.

Original:

Edited (objects above and below the intended level removed):
rorender_test

3 Likes

Thats gonna be a browser specific problem, make sure your browser is updated or try a different browser.

Hey this application never seems to work for me on any version. I did this on the basic city template. I installed the plugin, went into studio, opened the plugin, clicked auto configure, ran the exe of RoRender, clicked start server on RoRender, started up a local server with 6 players because i have 6 cores, waited until all players loaded in, checked RoRender… nothing happened, opened up the exe again…nothing.

Test 2: I thought maybe it was a firewall issue so i disabled my firewall. I did the same steps and it did the same thing it wouldn’t load the image, time would not start, nothing.

Here is my video showing what i am doing

1 Like

Did you click inject scripts on the plugin? I’m probably going to remove it in future iterations because a lot of people forget.

1 Like

yea it still never tried to make an image even with inject scripts

Video

1 Like

I’m having the same issue, it used to work, just now it dosent want to…

When i used it, it took a few seconds to start, and when I googled how many cores my cpu has, google was different than what Task Manager was telling me. Google said my cpu has 6 cores but task manager was saying there’s 4 cores.

Task Manager is accurate, because it shows you how many cores you actually have. As it a main application in your computer. It should know

1 Like

Yea when i tried with what google said the script gave an error, but when i went with what the task manager said it worked fine

Weird because i get no feedback from RoRender at all. It just sits there doing nothing, even after the steps that i needed to take.

1 Like

@Stonetr03
@CoolMeeskop

Any output in the studio window?

I got a render by having HTTP service on in the template game… i am an idiot i forgot this thing needs HTTP service to work i saw the error in the console… i am gonna try to get one of my game. The render of my game came out like this v … i will try to render a part of the map

One thing i noticed is a changed the size but its rendering a different part of the map aslo its being cut off… that might be because i tried to make a small size render but it didnt render that area selected… i thinks its rendering my entire map, which is good

Suggestion maybe tell people to turn on HTTP service, because if i completely forgot some people might aswell

I’m not sure what you mean here

I updated the post to include turning on HTTP requests

I wrote that part in a hurry as i had to do something. Here is a better version.

I am really bad at explaining.

I clicked Auto config then made the purple box smaller, but RoRender rendered the auto confgure instead of the smaller area. This could have just been a one time glitch.

The cut off of part i was referring to was the void i noticed it rendered the void as transparency.

Also here is the final render. I need to add water around my map. Its an old map i made so i am trying to rework the terrain. So stuff looks bad as of now.