Pressing Play does absolutely nothing

I tried to join my own game, but pressing this button
image
Does absolutely nothing.

Theres no ‘Starting roblox’ or any other frame appearing.
I’ve tried

  • Clicking and waiting.
  • Refreshing page
  • Restart computer.
  • Uninstalling Roblox Player.
  • I’ve tried different games.
  • Disabled adblock completely
  • Disabled all plugins

Nothing works.

I’m currently using chrome on Win10.
This button doesn’t work either:
image

Altho I can’t join any game, here’s a link to my game if thats relevant: https://www.roblox.com/games/177200271/Reason-2-Die-1-3-7b?refPageId=7018b7fd-3b9e-4df4-9f6d-8c6b8270e90f

EDIT:
Group pages doesnt load either, it’s just en empty screen:

A temporary workaround is to use Internet Explorer instead of chrome.

4 Likes

Does the issue still occur after disabling all browser extensions and reloading the window?

Can’t reproduce on latest version of Chrome – you might want to add more information on what browser you are using. (remember that How to post a Bug Report exists if you have trouble figuring out what to write)

2 Likes

Hmm yes, I disabled all plugins now and it still doesnt work.
I have the latest chrome verison tho because I dont have a ‘Update google chrome’ option in settings.

3 Likes

Why not try using a different browser such as safari or Firefox or edge.

3 Likes

I opened it in Internet Explorer and then I could join.
Thanks!

3 Likes

I can confirm the issue as I’ve started running into this issue as of today with Chrome on Windows 10 as well with the latest version of Chrome. Definitely seems it may be a wide spread issue among Chrome users that definitely should be brought to staff attention as Umbrella mentioned.

3 Likes

Are you able to load group pages?

1 Like

Just the same issue with the play button. Everything else seems to work just fine on Chrome.

1 Like

I would reinstall Chrome - you may have accidentally ticked the box and clicked cancel.

I’m on the latest version of chrome and still able to join Roblox games.

2 Likes

The exact same issues along with friends list not loading is happening to me and after: removing plugins, restarting Chrome, and closing everything else, it will not load. This just started happening out of the blue today, which kinda sucks because I play a lot of ROBLOX. Hope this can be fixed.

My Specs:

  • User agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.90 Safari/537.36
  • Platform Type: PC
  • Device Type: Computer

Same problem on my alt.

U can’t see the profil picture

Please start a new bug report for newly occurring issues. (this was fixed at the time)