Preventing Z-fighting of textures and parts on top of the texture?

I’m experiencing a lot of z-fighting with a texture.

I have a grid texture on the green baseplate, and then I have thin gray parts on top of the baseplate. These parts are 0.2 in thickness and sitting right on top. Ideally, this should block the grid texture from being seen, but the video below shows that it still has a z-fighting issue.

Does anyone have an idea of what I can do? So far all I could do is increase the thickness of the gray parts, but I really want to avoid doing that for my current use-case (parts needs to be nearly flush with the ground).

Here’s a short video showing the issue:


I don’t know if this would cause any issues for gameplay visuals or something you’d be apposed to, but you could keep the hitbox being flush and add a block mesh and just like 0.001 to the scale where needed to solve the issue.

Unfortunately, this issue doesn’t seem to go away until the parts are raised to about 1 stud up.

It’s worth noting that the camera is zoomed out quite far (about 180 studs); it just has a low FOV to appear closer.


Dang that’s unfortunate. I remember being able to do that to fix Z-fighting, but this was years ago. Not at home for the next 8 hours just about so I can’t help test. Best of luck.

why dont you just put part at the bottom(the green one) around all the edges of the grey one.

Believe this has always been an issue on Roblox. I don’t think there is a fix. Do you need the texture to show up while the block is meant to have z-priority or could you just temporarily remove the texture while it isn’t seen?


What’s your use-case? If you only need it as a visual effect, you could use a BoxHandleAdornment, which appears to not have this problem.

You could try making the size of the part of the y axis 0 and then turn on collisions and drag it down until its flat on the surface of the green part.

My current solution is to drop the grid’s Y position by a a factor of 200:1 to the camera’s Y position. In other words, I drop the Y position by: cameraHeight * -0.005. This has removed the problem for me. Again, it’s not very ideal though because you can still tell that the grid is dropping a little bit when zoomed out.


No way of fixing it rn, but what I do is either take the mesh to blender, and texture it in, then add it as a texture id to the mesh, or cut out the area where the part would be.