Problem with color correction and shading

I want to make it so the color correction value changes to 0, 200, 100 and the starter character have no shading.
I made some edits to my game and now it doesn’t work. This is the difference for what it looks like:
I only had a video* Before changes:
robloxapp-20230103-1931231.wmv (3.9 MB)
After changes:

After changes in-game:

I don’t know what caused this. I have a script that sets the color correction value to 0, 200, 100.

local ColorCorrection ="ColorCorrectionEffect")
ColorCorrection.Parent = game.Lighting
local Part = script.Parent

		if char then
			ColorCorrection.TintColor = Color3.fromRGB(0, 200, 100)

I did some tests before I made this and the results varied. Torso of starter character invisible, shading is gone. This is so difficult to figure out because I have absolutely no idea what’s happening to make this issue appear. This game is so stressful and difficult to make for me so why did this have to happen?..

1 Like

Did you turn global shadows off?

I turned global shadows is off already. I can’t 100% make sure because Roblox studio won’t let me but I’m pretty sure I turned them off.

I downloaded the video file, uploaded it into a video converter, then played it on my device. Here is a picture for anyone else trying to help:

Screen Shot 2023-01-21 at 1.50.06 PM

So basically the problem is that your game has no shading in studio but then has shading in game?

What is the problem with the first image? Is that different from the video?

In game it looks like the problem is ambient occlusion. Ambient occlusion is only enabled for higher graphics levels, you could see if turning down the graphics level solves that problem. I think other lighting modes don’t have ambient occlusion. You could try using compatibility mode.

You also might need to adjust the other settings of the ColorCorrectionEffect, like contrast and saturation.

1 Like

I might try to just set the ColorCorrectionEffect to enabled instead. I don’t know what compatibility mode is but using graphics setting 9 and lower fixes the shading issue. It’s just 10 that breaks everything.

Graphics level 10 has ambient occlusion, which is basically non-lighting based shading around edges. It looks super nice but doesn’t work with your effect.

Compatibility mode is a setting for Lighting.Technology. I would recommend trying changing it to see if that solves your problem (you can change it by selecting Lighting in the explorer and using the properties window to modify the Technology property).

1 Like

I tried compatibility mode but it didn’t work. I might try 2 things. I have UI on the starter character that covers it. I might try to make the normal parts invisible and see if that works and I’ll try the opposite. Edit: I made the normal parts of the character invisible only leaving the UI and it worked, now I just need to figure out the ColorCorrection issue.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.