Problem with Gui size

Hello currently I’m making a game in which after you die a gui pops up but I want it to cover the whole screen but it dosen’t cover the topbar.

I want it to cover the screen but how.

You have to toggle a setting on the ScreenGui element IgnoreGuiInset.

This just tells the GUI to ignore the top bar and count that as part of the screen. Otherwise it has the 36 pixel gap.


put this in a localscript in starterplayerscripts if you want to disable the topbar.

local starterGui = game:GetService(‘StarterGui’)
starterGui:SetCore(“TopbarEnabled”, false)

That’s not at all what OP wanted. They wanted the GUI to cover the whole screen. Disabling the top bar would not achieve this.