Problem With Lightning In A Big Room

Hey there, im currently making a reactor game and im building the chamber for it. But sadly the lights wont work as they should. I made a Surfacelight on every wall facing perfect to the center.
When im playing the game it looks like that:


Im looking for a solution to this problem, so it doesnt look weird.
Note: I set the graphic settings to max.


Lighting (and shadows) have a render distance that can be very annoying for large areas, even at max render settings. One method (if applicable to your situation) for lighting the room evenly is to toggle the CastShadow property on the ceiling to false and position the sun to directly above in the sky. This will allow the sunlight to fill the room. Sun lighting renders further since it’s applied to the whole game. If your game’s setting is at night, this may not work.

Unfortunately there isn’t much else besides doing other visual tricks to obscure or block far distances such as positioning background assets, using fog, blocking it in the foreground, etc.

1 Like

What I do when I have a large space needing to be flooded with light I usually place bricks all around the area set them to Transparency = 1 and then use lighting effects, if you place the blocks in just the right places you could get an even distribution of light. This is pretty much all I can think of, I’m not a very experienced developer as in having been hired and amount of projects, but in this situation this method should work, at least it does for me. I hope you found this helpful in some way. good luck my dude :ok_hand:

1 Like