Problem with Mesh Collisions

Hey everyone, I have encountered a problem with my mesh when imported in Studio. As you can see my character is floating above the light grey mesh in line with the dark grey mesh, rather than standing perfectly on top of the light grey mesh.

Image showing the problem:

Any help with the situation I’m in would be appreciated :slightly_smiling_face:


Roblox isn’t all that great with mesh collisions. The best ways around this are either too make the barriers on each side of your road separate meshes or to build them using bricks instead. Also if you want to see where else you might encounter mesh collision problems you can turn on ‘Show Decomposition Geometry’ in File>Settings>Physics>Show Decomposition Geometry. This will show up any potential collisions with multicoloured bricks.

Hope this helps :slightly_smiling_face:


Alright thanks for the helpful tips :ok_hand:

Hello there, i think what @penguim2 said above is the only solution for this issue.
It would be appreciated if you “solution” his reply, because why not.
This might be out of contest but i guess he deserves it, so i had to point that out. :slight_smile:

1 Like

Here’s a plugin so you can see the collisions of the mesh without having to go into the studio settings
you just click it to toggle on and off

1 Like