Problem with Region3

I am trying to do a region around an npc that detect any model in the region

I write a code and created a Region3 in it, but the return of FindPartsInRegion3 always an empty table even if the region was so big.

this is the code but it prints nothing :

local npc=script.Parent

local Point1 = npc.HumanoidRootPart.Position +,0,1000)
local Point2 = npc.HumanoidRootPart.Position +,0,-1000)

local RegionAroundNpc =,Point2)

while wait() do
	local ModelsInRegion = game.Workspace:FindPartsInRegion3(RegionAroundNpc ,nil,100) --get models in specefic region
	for _,Model in pairs(ModelsInRegion) do

Can anyone help fixing the code ?

OH MY GOODNESS! I had the problem earlier too. You need to print the exact name of the model not


hope this helped for you. I think that it has to be the name of the model. You cannot just use .name for almost everything related to regions.

I tryed also printing nothing, I tried to do break point and I saw that the table is empty

I fixed it, the problem was that the size was (-2000, 0, -2000) I Switch btween the point and it worked (now the size is (2000, 0, 2000)