Problem with sounds

Prior to installing the latest ROBLOX Studio update, my sound when clicking an invisible, non-collide-able part was working as intended. However, now it seems that when I click on the same unmodified part, the sound quality is so low to a point where someone would think that there was no sound at all.

Here is what I have on it:

  • An invisible non-collide-able part with the size of (6.67, 9.8, 1.89); taller than your player.
  • Script that plays an audio when clicked (indicated by ClickDetector).
  • EmitterSize: 10
  • MaxDistance: 20
  • Volume: 0.3 (the normal volume in which it isn’t too quiet nor too loud).
  • RollOffMode: Linear

Here is the result:

  • Sound is barely heard (even when I am standing ~3 studs away from the part)

I have noticed that if you walk inside the part (roughly in the center) before the sound stops, you can hear the audio normally. Any insight on what made this stop working would be fantastic. Thanks.

EDIT: Normal sound can also be heard if you rotate your character (first person) 180 degrees facing away from the part.

2 Likes

MaxDistance is based on the camera’s position, not the character. Try increasing the maxDistance and emitterSize.

Its is based solely on where you position your camera, nothing changed.

I understand that it is based on Camera position. However what baffles me is that when I look directly at the part that is emitting the sound, it is super quiet. However when I look away from it, the sound quality becomes normal again. My understanding would be that the Camera is positioned in the humanoid, though I’m not sure why it is behaving this way.

I just tried increasing MaxDistance and Emitter. No difference.

Are you able to provide a repro file for which this issue is occurring in? I have a feeling like it’s an oversight in regards to one of the sound properties but I could be wrong.

SoundProblem.rbxl (16.3 KB)

I have this problem too. All 3D sounds sound really muted unless my camera is directly at the source. I parent my sounds to attachments and parent the attachment to workspace.Terrain.

I went into a few games and it also had the same problem, 3D sounds were quiet.

I did some testing and it seems that the sounds ignore the EmitterSize property. I created a sound, parented it to a part in workspace. I set the EmitterSize and MaxDistance to 100.
The volume should be the same throughout. But when I move my camera away from the part, it gets quiet really quickly. When my camera is right next to the part, it is loud again.

Edit: It does seem to use the EmitterSize, but the volume still seems to fall off quickly even though my camera is in range of the part.

Were you able to find a solution? My audio was working perfectly a month ago until yesterday. This is the main reason why I am confused.

You can turn your in game Roblox volume to 1. Although this will make other 2D sounds really loud.

I tested this on another computer only to have the same issue. This seems like a Roblox bug at the moment. It happens in Studio and in games. Not sure if anyone else is affected by this.

I found a solution that is less effective than my original intent, but it will work if this issue is not fixed. Instead of having the sound playing from the part, I will clone the sound into the player’s character model and remove it once it finishes playing.

After playing around for a bit, I’ve found what seems to be the problem. The sound you are using tapers off at the end, which causes different results for testing. I’ve confirmed that this is not a bug, it is based on the distance from the camera.

New Repro to see my point: SoundProblemFixed.rbxl (16.0 KB)

Repro steps:

  • Click the door
  • Stand on the yellow part
  • In first person, turn towards the door
  • In first person, turn away from the door

The sound is the same facing and turning away from the door. My guess is when you got your results, you were not in first person. When you turn the camera facing away, you actually move it into the part, not away from it. The reverse happens when you move it facing the door.

Note that I simply changed .Looped to true to find this result, and increased MaxDistance to hear the sound better. If you want a more constant sound, increase the EmitterSize towards MaxDistance.

1 Like

When facing the door, the sound is muted; when facing away from the door, the sound is loud. The direction is correct but the volume is not.

1 Like

Your sound changes volume as it plays. That’s why I included the looping repro; It’s not different volume, it’s just a different part of the sound.

I’m so confused here.

The place shown in the video is from your repro above. The sound should be loudest when the camera faces the source, and quieter when facing away.

I found an example demonstrating this issue in a live game: https://twitter.com/DogePlayzYTReal/status/1172868688904691713

1 Like

Yes, the sound changes volume as it progresses, however that is not the problem. I found another video that showcases it:

Huh. That’s just weird. In this case, I’d recommend using Post Approval Proccess


to post a bug report in #platform-feedback:engine-bugs

1 Like

Ok, I found a solution. Turns out it is a Windows 10 update that caused this. I guess you can uninstall the update for wait for Microsoft to fix it.

https://support.microsoft.com/en-us/help/4515384/windows-10-update-kb4515384
image

2 Likes

You could be experiencing these troubles from the recent Windows 10 Update KB4515384. This update is known to have an audio bug that matches the description of your issue. I would look for other solutions first before uninstalling the Windows Update.

1 Like

Thanks for the solution; I had no idea Microsoft was the reason all along. Now that I no longer have the issue, I am curious what will happen to players who do have the update.

1 Like

Its really weird because i dont have that update installed (well i cant seem to find it and uninstall it.) and i sitll experience the issue.

Control Panel > Programs > Programs and Features > View installed updates
or
Settings > Update and Security > View update history > Uninstall updates

Look under “Microsoft Windows”.

Alternatively, just update Windows. They should have patched this already.