Problem with teleporting

Hi, I recently noticed an error that the character of player does not teleporting on the server side, only Primary part of character is teleporting. Also, the player falls through the baseplate

Video proof:

Can someone help me with this error, since I have not encountered it and teleportation worked for me without interruptions

1 Like

Is there a script inside of your teleport thing?

Try using CFrame instead of Position

I’m using a server script to teleport a player.

Oh great , do you mind sending it ?

Also so you’re telling me that the player is falling off the baseplate ? Have you checked if the CanCollide is off?

I tested it in my place, when I used Position I had your problem, but then when I used CFrame it worked perfectly.

You can see the line he was running at the bottom of the screen in the Command Bar

Oh yeah I didn’t notice that (sorry)

1 Like

Yes, you were right, i used position instead of CFrame. But why did this change, because i used position and character teleported

I have no idea, I guess this is just how Roblox works¿