Problems importing meshes

When I import a mesh that I exported from blender (fbx) it retries and never works.
Screenshot 2021-11-07 163451

I have tried so many times and it happens on every model I make!

Hey There,

Can I see the Triangle Count?

This normally happens when Roblox thinks there’s an inappropriate name in the meshes title. Try changing the name of the .obj and .mlt file.

Try and name it something else, even if it doesn’t suit with your mesh you are trying to import. If this works give @LegosAreGood05 Solution cause I just explained more thats all.

There is two problems that I know could be the cause to this:

  • High triangle count
  • Inappropriate file name

Maybe try checking and changing these.
Hope this helps!

This is a current bug that mostly gets resolved by or reinstalling Roblox studio, or logging out and logging back in.

It always says in red if more than 10k triangles and for inappropriate file name it says in orange. So I dought its the cause.


I tried reinstalling Roblox studio but it is still giving me the same error

If I try to import it into a mesh part it says inappropriate name.
I have tried many different names that are fine like hello so this isn’t the issue.

I had the same kind of problem, I was not able to import my mesh from blender into a mesh part, it would just show a loading cursor and then nothing, still the same.

The solution was: I changed the name to something I know Roblox would not moderate, I used the word ‘Model’ Try it, should work.

I know you’ve tried different names already like ‘hello’ but that’s the only fix I could think of


That’s very weird, try exporting using obj. Also maybe using mesh part like not a bulk import? Just try out different ways. Makes no sense for it to not work.

Same error with .obj. and with meshpart image

Weird question but is this the first time trying to import a mesh into studio, like have you done it before and if yes, is your account <13?

1 Like

I was importing the meshes on an alt that I put a random age in. I switched over to this account and now its working! I never thought about account age.

Im certain that if your account is bellow the age of 13 you won’t be able to upload meshes, just Roblox restrictions on younger accounts.