Problems with inserting decals onto models

Recently, I’ve been having problems with inserting decals onto models when they appear perfectly fine on the roblox website - they’ve not been moderated. I’ve tried replacing them with textures but that doesn’t work, I’ve looked all over the dev forum about this and there’s nothing. If it has actually been moderated, the icon hasn’t appeared and why would a carpet decal be moderated? (Keep in mind this decal has worked in other games).

This is the decal:

Is anyone else having problems with this and how do I fix this?

I’m experiencing this problem not in studio, but when it’s published… it is approved, but doesn’t show.

If the icon is showing up in ‘decals’ the decal just has to load. Be sure to choose a face for the decal, then wait a few minutes. You could start building other parts of your build while waiting.

1 Like

I’ve waited an hour for it to load onto the brick.

1 Like

Then choose another decal that one may have been moderated.
If you want I will upload that exact texture for you sound good :+1:

Sounds like it was moderated for some reason then.

Use Building Tools and then use the “Decal” tool to insert it.
Find a video on how to insert decals using Building Tools.

1 Like