Proximity Prompt not Triggering when Parent brick moved

  1. What do you want to achieve?
    I want to be able to move an object, in this case an npc, with a proximity prompt inside of it and have the proximity prompt still work.

  2. What is the issue? Include screenshots / videos if possible!
    The script works perfectly in every situation except for when the brick is moved to a location outside of the proximity prompt’s original range.

  3. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
    Looked for solutions here, most were found in the scripts but I believe there has to be some local/global inconsistencies here. The item is moved by a localscript in starterplayerscripts using the PivotTo() function. Although this specific scenario is an npc, we have this issue very sporadically with simple bricks and models. I am aware that local scripts don’t work in the workspace.

I have also tried cloning the prompt and destroying the old one, didn’t work. I tried cloning a new prompt out of Replicated Storage, didn’t work. I am looking for any advice now.

1 Like

I have also tried creating an entirely new prompt in the script and it still does not trigger. Could it have an issue with pivoting the model’s primary part?

1 Like

I mean you should just increase the range right?

1 Like

That would be a solution, but I don’t want the player to be able to trigger it from so far away if they get the right angle viewing it.

do you have streaming enabled?