"Publish to ROBLOX as..." does nothing

My game Twisted has a very expansive map, with a total part count of 346k. For this next update, we decided to set up a lobby system where players could choose to play the main game with the big map, or play a more mobile-friendly version with a less detailed map (a “LITE” version).

Today, we created the place for the LITE version within the same universe as the lobby place and main map place. I then attempted to publish the main map place over to the LITE place, so that I could begin removing things from the map to make it more mobile-friendly. I simply went to File > Publish to ROBLOX as… > Twisted Development > LITE Development Place. The publish button would grey out as if it were doing something, but then it would go back to being blue, despite not having published anything.

I then attempted to port everything over by just copy/pasting every single folder over. This sort of worked, however for some reason there is a major issue with z-fighting with my roads and other parts that are close together, despite them being fine and not having this issue in the main map place. I also ensured that every single property of every server entity (Workspace, Lighting, etc.) exactly matched those in the main map place. Everything is exactly the same, so I’m not sure what the z-fighting issue is being caused by.

Anyways, and this is the main problem, I then tried to publish the main map place to the LITE map place again, and this time, it actually displays “Successfully Published”. However, it is still not actually publishing the main map over to the LITE place. It’s not doing anything at all. I’ve verified that it’s not doing anything by moving a certain brick in the main map place, publishing to LITE, and then checking to see if that part is also moved in the LITE version. It literally is not doing anything despite saying it “Successfully published”.


Also, there has never been issues actually publishing the main map to ROBLOX, however, it’s pretty much impossible to publish it to any other place, or even publish a local file to it. Last month, I did attempt to publish a local file to the main map place, but it again did the thing where it greyed out the button before going back to blue without having done anything.

Not sure if this is just due to the shear size of the map, but if so, it’s really frustrating and something ROBLOX should fix.

Any help would be appreciated. Thanks!


I honestly think it’s just because of the size of the map that you’re trying to publish. I don’t know why it wouldn’t display any errors though, as it usually does when a place fails to upload. I would restart studio and your pc and try it again to see if it works.


I’d say it’s because of how big your map is. Try restarting roblox studio or your computer and see if that works.

1 Like

Tried this, and now it won’t say “Successfully Published”, but is now just stuck on the overwrite screen. It’s been like this for 45 minutes now.

I don’t have this problem with other places so yeah I think it is due to part count. Not sure where to go from here though because in order to set up the LITE version, I obviously need to publish the main map over to that place to get started on it. I assume it’s probably an issue with ROBLOX, but it really needs to be fixed ASAP.

I will stay on the publishing screen in hopes it finally publishes eventually, but i’m not very hopeful.

Thanks for replying.

Roblox (According to ChatGPT) has a part cutoff of around 20,000 for uploading new places (you can exceed this part count if you add onto an existing game) onto games. Therefore, I would breakup the game into smaller pieces and put them together in the new place. Let me know if that works!

1 Like

Thanks for the reply.

Fortunately I managed to solve this problem the other day. I was able to get an error out of it, which was the dreaded and notorious “Failed to upload union, exceeded limit” error. I was able to work around this by creating a local copy of the main place, then deleting all folders and publishing to LITE. I then added the folders back one by one, publishing each time, until eventually I found the 2 folders causing the problem. At that point, I was able to open the LITE map, and simply copy/paste the 2 folders over to there from the main map place. Then I was able to successfully publish it to ROBLOX.

I’m still having this exact same issue, except studio won’t give me any error essage to why it happens. Even trying to save the game takes a long time to accomplish.

Eventually found out my issue with this was because I exceeded the union limit when publishing. It’s a common error that ROBLOX just hasn’t fixed despite it occurring for years. Only way I’ve managed to resolve it is copy/pasting folders individually into the new place and publishing each time, so each publish is broken up into chunks of content rather than publishing all at once. Really tedious process.

1 Like