Question on why things I build in studio are not showing up in game

I’ve been having a very odd problem as of late while updating games. I have updated multiple of my games (I understand that experimental has been turned off) but every time I update my games anything that I build in studio does not show up when I actually join my game. I don’t know why this is happening, if anyone knows a solution it would be greatly appreciated :slight_smile:



Are you publishing to Roblox or to the Cloud?

There is a SAVE to ROBLOX and a PUBLISH to ROBLOX feature. Make sure you are clicking publish to ROBLOX instead of save to ROBLOX.


I’m publishing on team create so it should be roblox.

The way to do it with Team create is, Make everyone leave (Quit the team create) then the last person saves the game. Thats the way I have always done it.

EDIT : And have done this for over a Year.

EDIT 2: Let me know if this has worked for you!

1 Like

Just checked a developer hub article on team create: Team Create | Roblox Creator Documentation

This is probably why you are experiencing the issue as you can’t manually save it auto saves every five minutes. So when you manually save and play it hasn’t actually saved.

HOWEVER there is a chance this hasn’t been updated with the new save feature.

It worked thank you so much! - disneynutty1398

Which method worked? My method or Alex’s method?

I had to use your team create method and then I also used alex’s to help figure out how to save it correctly.