RBXL Files have no icon

This began within the last few days. RBXL Files on my desktop and anywhere else don’t have a Studio Icon. I keep almost deleting them thinking they’re FBX files I no longer need.


I’m on macOS Catalina 10.15.

Can’t think of what else to include here! I’m not sure when specifically this started. I normally use Studio to find my files.


Can confirm for the newest version of Windows 10 as well.



I’ve been experiencing this on MacOs 10.14.2 for the last few days


1 Like

Can confirm that this is a bug. Running MacOS 10.15.1 .

Experiencing a similar issue on Win10

This is still not fixed although it might be intended behavior because even if you force a rbxl to open with studio, studio just brings you to the start page regardless. I wish they’d bring back this functionality!

I’m still experiencing this issue. Was a resolution found and this is a resurgence, or was this never fixed on MacOS?


I’ve also been experiencing this. :confused:

1 Like

I have always had both RBXM and RBXL files to be without a Studio Icon. I don’t know if this is Mac-specific, but I’ve had the latest Mac for 3+ years.

Thanks for the report! We’ve filed a ticket to our internal database and we’ll follow up when we have an update for you.

1 Like

just checked my files, and… P A I N

i think that while updating roblox studio , it just bugged out and acciadently changed the place or original icons. i think here is the problem

I know a possible solution to missing icons on .rbxl files, but unfortunately only on Windows 10.

First, you need to go Windows Settings > Apps > Default Programs (scroll all the way down) > Choose default apps by file type

Scroll all the way down until you find .rbxl file and click to assign the default program to Roblox Studio.

Unfortunately, I cannot help macOS, but I hope this helps those who have this problem on Windows.

This used to happen when i updated, for some reason.

1 Like

We literally wrote at the same time lol