Windows does not automatically use Studio to open Place files after Studio updates

Every time Studio updates, it forgets to bind rbxl and rbxlx files to Studio. The file associations are broken and I have to reset them to open all of my place files.

This is incredibly annoying, impacts me 100% of the time after Studio updates, and has done so for a few months now.

This is problematic for my development workflow as I constantly use local files compared to cloud places for various reasons.



Hardware Specs

CPU: Intel Core i7 2600 @ 3.40Ghz
RAM: 8GB Dual-Channel DDR3

OS Version

Edition: Windows 10 Pro
Version: 1903
OS build: 18362.418
64-bit based operating system, x64-based processor


After last night’s update, I can confirm I’m having the same exact issue. Studio seems to have moved itself from %appdata%/Roblox to Program files (x86)\Roblox. I can’t uninstall studio or even re-associate the file types, I can only get studio to open up to the home page when trying to re-associate the file extensions.


I had this issue fixed unintentionally while following the instructions here:

It seems that it running on admin makes it so it can’t properly register the file type*?*

1 Like

Yup, that did the trick. Thank you! Apparently opening any rbxl/rbxlx files from the command line forces studio to run as an admin, which cases the issues.

1 Like

I’m a bit late, but after trying, it still didn’t work for me.
But I found a solution and I hope this helps to people who still have this problem.

First, you need to go Windows Settings > Apps > Default Programs (scroll all the way down) > Choose default apps by file type

Scroll all the way down until you find .rbxl file and click to assign the default program for .rbxl files to Roblox Studio.