Reasons why ReserveServer would freeze indefinitely

local code = TeleportService:ReserveServer(place_id)

This one line of code seems to freeze the entire script indefinitely. I’m testing in a live server. Is there any reason why this might fail? The script is a server script, I’ve triple checked the place_id variable, and a print statement the line previous verifies it compiles to this point. I couldn’t find any reasons on the wiki, if y’all can brainstorm with me that’d be great. Thanks!

1 Like

plz help

It is a yield function so it might be due to any other scripts you have running.
Can you replicate this in a blank server with just the teleport.

1 Like

Is the place id part of the same game as the place you are running the code in? Does it fail every time or is it intermittent?

1 Like

The server really is blank as it is - the only other code I have running is a remote event that fires the entire thing.

So the place I am running it in is a the game universe’s starter place. I am using the place id of one of the other places under that same universe. It fails consistently.

For me, I just get an error saying ReserveServer can only be called from the server even though I’m literally calling it from the server. I tried without remote events, nothing worked. Tried a module script required by the server, nothing. And I’ve seen a couple of people experience the same bug I’m experiencing.