Recent changes to AlignOrientation 100% broke my game

I had an AlignOrienation inside a part. It worked as intended around yesterday. I published the changes to my game today, without restarting studio, and I realized the responsiveness did not allow the part to be moved to its intended orientation in-game. It felt impossible to debug because it worked completely normally in studio.

When I restarted studio, the bug occurred and did not orientate to the correct orientation with a low responsiveness.

I am positive that restarting studio caused the issue which makes me assume something has been changed with AlignOrientation.

I’m assuming something was changed? If so, what was it? Has anyone else experienced this?


Have you closed out of Studio and reopened it yet to see if it was a momentary glitch on your end?
If that doesn’t fix it maybe Uninstalling and reinstalling Studio.

Also this isn’t really a scripting support issue.

1 Like

Yes. I published it to my live game and it occurs there. After I published, I noticed the bug in-game but it did not occur in studio. I spent an hour trying to figure it out. Then I restarted studio, and it happened in studio afterwards.

I was in a team create and the bug did not occur for my friend until he restarted studio also.

	root.AlignOrientation.MaxTorque = 5000
	root.AlignOrientation.Responsiveness = 40
	if,0,player.Character.HumanoidRootPart.Velocity.Z).Magnitude<0.3 and (alignPosition.Position - root.Position).Magnitude < 1.5 then
		root.AlignOrientation.CFrame = player.Character.HumanoidRootPart.CFrame
		root.AlignOrientation.CFrame = CFrame.lookAt(root.Position,, root.Position.Y, MoveToLocation.Z))

I have restarted studio several times since. Above is the part of code that I’m referring to.

It feels like they may have changed the responsiveness property. If I increase the responsiveness, the part orientates to the correct orientation. Otherwise, it just points in a direction that makes 0 sense.

I did not change any physical properties. In fact, I basically changed nothing from the game when I published.

1 Like

Are there any details of this part? relates to the below question.

I see that network ownership has not been mentioned, have you ensured the network ownership is correct and belongs to the correct owner?

I can’t think of anything else haven’t seen a change in #updates:announcements or followed closely enough.

1 Like

I thought that also.

I tried increasing the Incoming Replication Lag in studio and decreasing it. It does not change my issue. I also searched through announcements and didn’t find anything about this.

Network Ownership of this part is set to the client from the server.

1 Like

Responsiveness 80 which now works:

Responsiveness at 40 which worked completely fine previously but not now:

1 Like

I am now 100% positive that they changed something with AlignOrientation that broke my game.

I booted up several old saves of the game that worked as intended. They now have the same bug of the part spinning around / looking in the wrong direction.


Can confirm I’ve also experience a sudden game breaking behaviour in relation to AlignOrientation. For me this issue has arisen in the last 3 hours or so.

Also had another game breaking bug occur with PrismaticConstraints during the same time. I’m thinking these must somehow be related as this also involves having a low Responsiveness


Let me know if you hear any more information about it.

1 Like

I may be completely wrong here, but they’re slowly rolling out lower rate physics simulation and that may have caused an issue potentially.

See what changing Workspace.PhysicsSteppingMethod to “Fixed” does.

More info:


You are correct. 240hz and it works as intended. Thanks

My game is broken also, with serious problems in the AlignOrientation used to control the rate of turning. It was working fine yesterday. I would have appreciated some sort of announcement or warning that physics is going to be completely different after this update! /cc @KnightGaladeld @Focia19

1 Like

+1 also facing this issue; I’ve mitigated the problem by adjusting Responsiveness and PrimaryAxisEnabled, but the issue still occurs intermittently.

ETA: Updating Workspace.PhysicsSteppingMethod seems to have helped! I have to look into any potential side effects of using this though.

Do you have the link to the release notes or documentation on this physics update?

My bad, I should have mentioned it initially.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.