Recent Studio Changes (Likely) Breaking Animation Blending

A few months ago I created a Character Animation Script, and it allows for strafing and backpedaling animations which blend very similar to Roblox’s own system for this. What’s strange is that it worked perfectly fine when I made it a few months ago, however, now the animations start tweaking out when a Forward&Backward animations blend with the Strafe (Left&Right) animations whilst moving diagonally. Basically when the animations try to blend they start glitching out everywhere and are out of sync despite the time positions saying they’re in sync. Something is possibly wrong with the animation player.

I believe this is caused by some recent changes/updates to Roblox because It worked perfectly fine before and I have not changed the framework/script whatsoever. I also tested it on a backup that was created right after the system was made, during a time when it was working fine and certainly had no changes, and it too was having this problem. I decided not to post this to Engine-Bugs thread due to my uncertainty.

Here’s what the issue looks like:

All of the animations are under the ‘Movement’ priority, the tracks have varying weights, however, changing them to be uniform showed no results. They all use the same speed, and as mentioned, the time position is properly setting to sync with the other animations just like before when it had worked.

I’m posting to see if anyone has encountered any similar newly appearing bugs or issues, and ideally a fix of course, before I extensively spend time to try and deconstruct the issue or eventually make a detailed post about my script and what I’ve tried. There’s also the possibility of course that its a bug out of my control.

2 Likes

I’ve been having the same issue, and it completely breaks my game, and single-handedly dropped my like to dislike ratio 16%. I made a dev forum post, and no one will respond, it seems that no one in the world cares about this issue except me.

1 Like

Suppose we should try and report it as an engine-bug then, seeing as I am certain it is not our fault but something done by Roblox. I’m not even sure if we can fix it if we try so I’m not even gonna bother wasting the effort. I’d recommend trying to find an alternative for your active game for now.

Well, I have tested once more just now and the animation blending appears to be working once again. I am interested on if it is working for you as well, please LMK. But for me, the problem seems to be fully fixed for now.

It had been 100% fixed now, was fixed ingame, though was still broken in studio, I have not checked if it was fixed in studio in the past couple days, but reguardless it being broken in studio for longer while they try and fix won’t effect my game.