RemoteEvent not firing

  1. What do you want to achieve?

I want to have two gui’s to hide when intermissions ends and game starts. Then after the game ends (or when the intermission starts again), I want them to reappear them again.

  1. What is the issue?

Even though the remote event script are the same, only one of the GUI is showing but the other one is not. At the beginning when I want the two remote event to fire after main menu is over to show the GUI, it works for some reason, it’s just at the end it’s not working.

Here are some screenshots of my code

The ES remoteevent is the not working one.

The not working one code

The working one

  1. What solutions have you tried so far? Did you look for solutions on the Developer Hub?

I previously made this topic, tons of people decided to help me (cheers whoever tried to fix my code) but none of them seemed to work. I have also looked other topics relating to this, still no success with my problem. I even put the print statement when the local script have received the remote event message; all the other remote event I put in the main script have successfully worked, saying SS and ES in the output, but at the final remote event code, it only says SS. Please can somebody help me with this, it will be greatly appreciated because I have been trying to fix this problem for 3 days now, and the fact I have tried nearly everything to solve this and it is still not working is irritating me a lot.

1 Like

Bro there problem if you made this ?

If you put equippedItemviewport in SS Remote?

And there no errors in your output?
if not show me script thats have remote event


You may need to post a full script or more code for us to help. Is there some infinite loop which prevents the script from reaching the .onClientEvent line? Something outside of these lines may be causing it to not work.

1 Like

ok, let me send you all the remote event code I have put so far

the first one:

The second one:

The third one:

Feel free to ask me for more pictures of my code

the output does not show any errors what so ever

and also the ES remote event script is place just behind the variable, so there is no possible way that the onclientevent line is not getting reached, and also as I said before, it worked when I put the remote event the first and second time, it is just only the third time that the ES remote event decided to not work anymore.

In all pictures ES CAN’T reached ?
If that and Ss working show me local script it have ES

Wait on the third time, ES doesnt print while SS does?

nope just the third picture the ES doesn’t work, the first and second picture I posted 5m ago, the ES remote event works.

yes that is most certainly true

try swiching the Line ES and SS togeather on all of the events and see

Ok I’m going to see if it works rn

dont ask me why because the reason is off-topic

unfortunately the suggestion of yours doesn’t seem to work

ok wait a minute let me see what is happening on the things

Everything seems to be right the script itself might be corrupted

what do you mean by corrupted?

nvm its nothing i just going to say the script is broken

is there anyway to fix it, or does the script have to be rewritten?

try restarting your studio (and make sure to be on the lastest update for good measures)