Removing Chat Type & Avatar Appearance Override Settings


#21

Yeah, I agree, i can update the post to include that, i saw that Seranok posted this

and wasn’t sure I should update my post or not.


#22

I feel like it’s helpful for the experienced, but an obstacle for the new.


#23

Here is another way to enable bubble chat.

I think the problem is that changing the lua chat settings is not very discoverable right now. This could probably be fixed by better documentation.


#24

Are you ever going to give configure pages a facelift? Right now they’re still just a mess of buttons. I imagine it’s a simple page to style, you already have all the elements (settings page)


#25

I think in the long run they’re going to move everything to the settings menu in studio. That’s good since it won’t take 30 minutes to load the page anymore.


#26

Oh, that makes sense ty. I would prefer to have both options in case I couldn’t access Studio, although I did notice more settings in game settings and I think that’s a really good addition.

I feel like some settings such as avatar settings should be in relation to the place file instead of the game, just so you don’t have to publish the place each time if you’re working locally to reflect avatar settings (also allowing you to choose between options in different places if neccessary?). Just my feedback on that


#27

@Seranok I can’t find a way to enable BubbleChat in my newly made place. All the wiki and devforum resources I’ve read do not work. The code in the original post isn’t working for me in a LocalScript, and uploaded & played online. It works only in studio.

local function setUpChatWindow()
    return { BubbleChatEnabled = true }
end
Chat:RegisterChatCallback(Enum.ChatCallbackType.OnCreatingChatWindow, setUpChatWindow)

Can someone double check if this works for a new place, uploaded online & not in studio?

Here’s the place I’m testing it at. https://www.roblox.com/games/2795061593/ybc So far it looks like bubblechat isn’t getting enabled online

Also, this code doesn’t work, but the wiki implies it should:
game:GetService("Chat").BubbleChatEnabled = true

This code also doesn’t work online (only in studio), but the wiki implies it should too: :upside_down_face:
game.Players:SetChatStyle(2)


#28

I’m not sure if it was mentioned, but did you try editing the chat settings?


#29

Still REALLY think this should be a thing. I don’t think we should have to do all this for something 95% of games use.


#30

the point is to avoid making a fork of the chat scripts


#31

I experienced the same issue for about three days ago. Ended up with me doing what @TheeDeathCaster suggested.


#32

Put this in the ‘Chat’ in studio explorer, it’s edited to give players bubble chat. I was having the same issues and did what Clonetrooper suggested.


#33

They should really consider this to save us the trouble.


#34

We tried to made this as a property before while we discovered that it did not safely preserve the web settings for old places that might be out of maintenance and accidentally broke bubble-chat only places. So we reverted the change at first place. Thanks for your suggestion and we will come up with more solid solution in the next few releases.


#35

I have tried the this code

local Chat = game:GetService(“Chat”)
local function setUpChatWindow()
return { BubbleChatEnabled = true }
end
Chat:RegisterChatCallback(Enum.ChatCallbackType.OnCreatingChatWindow, setUpChatWindow)

it works for my own place online


#36

I agree on removing the Avatar Appearance Override option, however for the Chat Type, I don’t think it is a really necessary to remove it from the WebPage but it’s still fine!


#37

We investigated making this a property but this would incur significant implementation complexity. Additionally, we want to have a unified way to configure chat settings, which you can read about here: https://developer.roblox.com/articles/Lua-Chat-System/API/ChatSettings


#38

Should I insert this script into the Workspace?


#39

StarterPlayerScripts is a more suitable location.


#40

Oh, thanks for clearing that up. I tried inserting it into StarterCharacterScripts and ServerScriptService earlier with no luck :tongue: