Removing sky light from dark areas

I’m working on a dark bunker, but the sky light keeps getting in. There’s a daylight cycle, so no switching it to night.
Any suggestions, or solutions?

Screen Shot 2021-06-19 at 6.02.27 PM Screen Shot 2021-06-19 at 6.02.37 PM


your gonna need to make the root more thucker or create a plane part above the bunker.
the more thicker more shadow it will cast on the objects bellow it.
that is one way of removing the sky light at corners.

this corners are just there cause you have not made the walls/roof thick enough.
so or you increase the thickness of the walls or you create a part above it to cast shadow in it.


I’ve tried and made the walls more thick, but it still stays. I also can’t afford to put a plane part above it because I have an environment there.

1 Like

Here look at this screenshot someone a long time ago had this issue.


Roblox works with a 4x4 voxel engine, so either when your in the bunker you make everything dark or you have to sadly deal with the light sepages.

1 Like

you can script the part to only display when you are inside of the bunker, and once you are outside it become invisible or even destroy it.
so wharever yo uenter in the bunker it willcast shadow.
and you make it local.

Try changing the Ambient or OutdoorAmbient settings.


Otherwise, try making a bevel on the walls (curving the corners)

Maybe make sure the walls & roof are all touching with no gaps (or even clipping into each other) and union them. I’m no expert but it doesn’t hurt to try

It’s not a great fix, but it works.

Build an extra box larger than the map itself and put it around the map. Make the box around 4 studs thick, or more. That should get rid of the sky light. If it doesn’t work, make the box thicker. If it still doesn’t work, duplicate it, make it larger, and put it around the previous box.