Reporting wizard has previously created report data filled out

A minute ago I attempted to post a new bug report in #bug-reports:website-bugs however the report wizard was already filled in with data that I had entered for a previously published bug report.

Upon just clicking post to get the screen out of my way and to attempt to try again, it bought me back to my original post, however it also created a new duplicate of said post in #bug-reports:website-bugs.

This was incredibly annoying since not only does it make it look like I’m breaking forum rules but it is an extra annoyance to a user who is likely already annoyed at the fact they are even having to write a bug report.


Draft misbehaving aside, why would you click post again? The effect of doing that should be obvious. :confused:


If we were to look at some user psychology in the bug reporting process you can likely safely assume two things:

  • firstly the user is annoyed at having encountered a bug

  • secondly the user is likely in a rush to get back to how they actually should be spending their time

When faced with this scenario and in this sort of mood one finds themselves simply clicking the biggest button they can on any screens they don’t expect to see, such as a confirmation screen when they are expecting a report screen.

There is also the factor that it’s a bug, and as a experienced developer I am sure you are experienced with the fact that if something breaks there is likely to be a chain reaction which leads to other implications, e.g. the bug report not posting.

If it were not for the fact of my curiosity I likely would have never even have found the bug until it was flagged down since as stated in the post it then proceeded to redirect me back to the original despite creating a new post.

Furthermore, as an experienced developer you should know better then to blame users for a bug - or the effects of a bug - that they did not create so long as they do not try and abuse said bug. Here I took the proper action of trying to delete the post and reporting the bug and yet still I wake up with feedback DMs making it appear as if I’m in the wrong.

I would also point out I tried to delete the duplicate post but because of some absurd change, pressing delete seemed to only lock the post and not remove it, also disallowing my ability to edit it.

It looks like the wizard making a duplicate post is simply user error.

I did however have a similar experience today where I opened wizard to the second page which was part of a draft, pressed back to change the category to Engine, and then pressed next to change the title, but that just redirected me immediately to the last bug report I posted and closed the wizard.

Took a video of the bug, as I was palnning to make my own bug report about this bug, however, I see you’ve beat me to it. Hopefully this can shed more light on the issue, and get it fixed. My bug report from June 13th was already filled out.

I have tried re-opening the wizard a couple of times, to see if I could get it to clear the old information. It’s not budging. I pondered for a second just hitting Done to see if that’ll make it clear, but figured I shouldn’t do that as I don’t want to make a duplicate post about a bug that has already been fixed…

But from a user stance, it’s easier to click through than to go through, delete all the info previous placed, and then input your new info.

Not sure if related to the former draft being pulled up, but trying to add new media to any of the sections results in a stuck loading situation,

1 Like