ResetButtonCallback isn't disabled for Mobile devices when StarterGui:SetCore("ResetButtonCallback", false)



local CAN_RESET = false

local function doSetCore() --! Annoying StarterGui
	local StarterGui = game:GetService("StarterGui")

	local function disableReset()
		StarterGui:SetCore("ResetButtonCallback", false)

	if not CAN_RESET then
		while wait(1) do
			if xpcall(disableReset, disableReset) then

Repro.rbxl (28.6 KB)


I can reproduce, and it does not appear that the ResetButtonCallback has worked in the mobile emulator or on an actual mobile device, despite working on PC.

However, upon trying to click the reset button, it does not actually work and it will not let you reset your character, though it does appear you are able to until you try due to this visual bug.


As mentioned above, you would not have to worry about mobile players being able to reset their character. They can click it, but when they do, nothing will happen.

This is just a bug with the button being clickable.

Thanks for the report! We’ve filed a ticket to our internal database and we’ll follow up when we have an update for you.


I just tested with an iPad, an Android phone, and in Studio.

And the features worked perfectly, and consistently.

Can you provide more info on when this is not working? @kevinluxury @RuizuKun_Dev

Edit: Thanks for clarifying the subject. I have not tested that aspect specifically.

Edit again: Stuff that might be muddying the waters is that depending on how you set up your code,
you may need to disconnect your event on each callback. Also there of course, you should use pcall

1 Like

Try playing a game such as Stateview Prison and try to reset your character on a computer and also try on mobile.

On the computer, the reset button will appear as disabled or a lighter shade and not clickable.

On mobile, the reset button will appear enabled and look normal. When clicking it, the game will ask if you are sure you want to reset or not. Click reset, but nothing happens.

It is disabled either way. It just appears differently. Hopefully this will answer your question.

Yes, thanks. I have since confirmed this UI bug after reading your earlier response, which clarified.
This bug seems familiar–Is this a longstanding bug or a regression?

This is a longstanding bug for a long time.

1 Like

This is also happening in Studio’s Multi-Client simulation

This is most likely an issue with how Roblox added ResetButtonCallback.

Originally, what currently happens on mobile was intended behaviour until the disabling of the button came out. (except it was never added to mobile)