Resizing errors?

I am using 1, 0.5, 0.25, and 0.125. So EVERYTHINGs position should be within 0.125. But somehow, certain parts are getting like .002 or .003. Why?? Becoming incredibly frustrating and tedious to try and get parts to all be in the right postions.

I’ve tried using both SBS and F3X and both do the same thing. Using 0.125 to resize, it’s size 0.625, but it’s position 0.562?


Welcome to Roblox rounding errors. Also, are your parts rotated when you are resizing them as that would explain the positions looking weird. A video or GIF would be useful to see what is happening in more detail.


Does the same thing happen with the Transform tool?


Haven’t tried, but in my opinion, it could happen with the Transform tool.

1 Like

I have seen this happen when I use bigger intervals such as your case, “.125”. This was a common issue for me when I was a new builder, that is, until I switched to a more uniform scaling. Currently, I use 1, 0.5, 0.2, 0.1, and 0.05. This tends to work much better. Although some may argue that the degree “0.2” doesn’t fit within the scaling of “0.5”, I have a strong reasoning for why it does, in fact. When coming up with size errors with the “0.2” interval, I can always easily fix it by going back an interval to say, “0.1” or “0.05”. I usually stick to the standard Roblox Tools and use F3X occasionally, and I never see your positional issue anymore. Hope I could help you out!


Default tools are more reliable, they tend to be very exact. Welcome to the world where floating point error exists.

This affects: Orientation, size & position

1 Like

Floating point errors generally shouldn’t occur when the increment is a power of two (.5, .25, .125, .0625, etc.)

I think OP’s problem is caused by the position changing by half the resize increment (.5 + .125/2 = .5625).
Try holding shift while resizing to lock the position.

Roblox Studio also only displays thousandths. It may say “.562” but it’s actually “.5625” (We really need a setting for higher precision)


Because machines runs on anything that goes with power of 2. It is logical those shouldn’t occur with those increments.

Relevant numbers are: 8, 16(bits), 32, 64, 128, 256, 512, 1024.

Oh, and add up with binary. 1s and 0s.

1 Like

Make sure the part is not being rotated when you place it in an another position because it will be a few increments off.

It also happen to me sometimes, I didn’t find answer too, but maybe a day there will be a solution.
And when it happen I advise you to collide the part to another and resize it with precision.
(It’s what I do)

1 Like

This happens randomly and is a quite frequent frustration of building. Normally this happens when unioning, but I’ve seen it happen other times as well. The only way I’ve found to fix this is to undo everything and then rebuild it.

It does.


1 Like