RESOLVED: "Failed to load settings with SslConnectFail" Studio Error Message, Feb. 2024

Hey everyone,

As I do not have access to post on the Bug Reports category yet, I hope this will be visible to some who will help me with a particular issue I started to encounter yesterday, 2/22/2024.


This error message has been popping up every time I try to open Roblox Studio by itself through the application and via the website edit option.

I am experiencing this error on Windows 10 and I’ve reinstalled Roblox Studio and cleared my Roblox website cookies as potential solutions but both have turned up for naught.

There is another post on the devforum that has solved this issue. However, it does not explain how they fixed the error: FIXED - "Failed to Load Settings with ConnectFail" Error in Roblox Studio

Hopefully, this post will be able to help others in the future.

Thank you!


Updates to this issue:

I have discovered that this issue also correlates with the Epic Games launcher. When I try to launch the Epic Games client, I am confronted with the “AS-3” error code. This article,, explains that the common troubleshooting solution to that error is to enable IPv6 connections on your home network. I have enabled IPv6 and unfortunately, the error code is still occurring.

After reading this article, I contacted my Internet Service Provider and they have assured me that there are no problems with their services on their end and on the router and modem that I am using.

Other troubleshooting options I tried ranged from launching the CMD prompt in administrator mode and flushing the DNS of my network to logging into my router’s local settings and port-forwarding specific ports used by Epic Games and Roblox.

I also came across this devforum article, HttpError: SslConnectFail error when acessing various assets, where @0xFooBar has stated that,

Disabling IPv6 did not help my issue.


After endlessly searching online throughout the weekend for solutions to this frustrating problem and rigorously uninstalling and deactivating programs on my computer, I found out that my antivirus program, Kaspersky, was the root of all the problems.

I deactivated the protection and opened Roblox Studio, and it finally launched. There was a Roblox Studio update that I installed and after it was finished, I tested if the recent update to Studio helped with the compatibility between the two programs. I reactivated the Kaspersky protection, and it seems to be working fine now.

I hope this post will help others with a similar situation!


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.