Revert version feature isn't working?

Our ex team member deleted some of our work… Can anyone please help us about how we can get our work back? We tried reverting the version but it doesn’t seem to be working. Is there a way for us to get our work back?


Reverting the version would work. All you need to do is make sure everybody in team create is not in studio, revert the version, then go back into studio. It won’t happen if anyone is in studio.

I did it. I selected the version, clicked “revert to this version”, confirmed it by clicking revert and it didn’t changed the version.

Did you make sure to press “save” after you clicked “revert”?

I did. To be more clear.


After I click revert and save:

Looks like it didn’t actually revert. I would give it another go, disable any ad blocking/tracking extensions if enabled as they may interfere.

Check for auto-save files.

Version reverting does seem to take some time to apply though.

I tried disabling al of my extensions. Still didn’t work.

I will try to find auto save files for it. Thanks.

1 Like

You are meant to revert it, THEN go to studio and publish it.

I joined Studio to see if it’s reverted. It was the same. I don’t think that publishing it will change anything.

Oh, it worked for me before.

Is it needs to be published? It can be the problem.

I’ve had this issue before (recently, in fact), and from my experience, the version shown on the page is for some reason one version ahead of what it actually is. Whenever I needed to revert to a previous published place, it always forced me to go to the version before it.

I’m not sure why that works the way it does…
Also yeah, make sure to do all that other stuff the others said, like making sure no one else is in Studio at the time. Probably might have to wait roughly a minute or 2 to really make sure it was reverted successfully.

I’m writing this if somebody else had the same problem… You need to have the version published to revert to that version. That’s why it wasn’t working for me. Because, the version that I was trying to revert wasn’t published. Because of that, the version wasn’t reverting. I thought that the feature wasn’t working and created this topic. Please don’t waste time like I did. I hope this will be helpfull for you. I will make this the solution so more people can see it. Have a good day.