Rig Attachments are in The Wrong Places and I Cant Move Them

I’m using a custom r15 mesh rig and the attachments seem to be off as the positions of them are based on the Robloxian 2.0 rig and do not suit what I need. What I’m trying to do is fix the position of these attachments so that the accessories loaded onto it look right.


-After player loads:

Ive searched the Devforum and I couldn’t find any answers, i’ve tried moving the attachments with the Roblox studio tools (they go back to normal) and i’ve tried changing the values that are in the attachments.

Is the humanoid also R15? If not then change it to R15. If it is already R15 and the issue still shows up then try using the normal blocky R15 roblox character. If that doesn’t work either then we can see after you try or reply.

Yup its also R15, and it would probably work with the rig type the “skeleton” was made for but this is a custom rig so the attachments are were the head would normally be (the addition of the neck lifts the head up but not the attachments)

If the attachments were rigged in blender, you probably have the wrong origin. I have better luck setting the rig and part the same.

If they were made in Roblox, you need to adjust this value.

The weld is based on the Origin Position. Position follows Origin Position, but not the other way around. manipulating Position while leaving Origin alone should allow you to reposition it on the body.

(I think… I have not had my morning caffeine.)

Origin position doesn’t exist for attachments, however I tried changing position and it would just go back to its old position when I press play.

Use rig edit it lets u edit the motor6d bones

but is that related to the attachment?

True, I’m modifying the mesh/part the same way I would position a tool. No idea if there is no part.