Rightclick context menu offset from mouse

Reproduction Steps

I tried reinstalling studio, restarting my computer, resetting my layout, and nothing seems to work. It just started doing it out of the blue, and idk why.

Expected Behavior

When i rightclick, it opens the context menu at the mouse’s position

Actual Behavior

It opens up away from the mouse, and goes at different distances based off the size of the window itself. If i make the window smaller, it ends up further away from the mouse.

Workaround

No.

Issue Area: Studio
Issue Type: Display
Impact: Moderate
Frequency: Constantly
Date First Experienced: 2023-01-23 00:01:00 (-05:00)
Date Last Experienced: 2023-01-23 00:01:00 (-05:00)

6 Likes

Started occurring for me too (mouse is over the part)


image

1 Like

I also have this issue, except that it only happens when right clicking in the viewport or the explorer. When right clicking anywhere else (where I’ve tried) it does work like it’s supposed to.


Update:
When I move studio to my secondary monitor and right click in the viewport or explorer the context menu gets clamped to inside of my primary screen, even though the entirety of studio is on my other screen.

Also, when the game is running right clicking the explorer works like it’s supposed to.

My primary screen is 1920x1080 and my secondary screen is 2560x1440. The issue still occurs when I unplug my secondary screen.

Do you have a high DPI display?

no, im using a standard 1080p screen.

2 Likes

Oh yes I seem to have the same issue. Sometimes the mouse snaps to a new position or clicks in strange locations also.

1 Like

I have noticed this issue is dependent on window size, if I use a different size monitor its off by the difference. As well as if you have the tool box or output open, it influences the offset. Hope this gets fixed soon.

This is happening for me regardless of viewport size or emulator setting, with one screen.

System info:

Display settings:

Display resolution: 2560 x 1664

In this case I believe DPI scaling should be at 100%.

Kinda annoying for UI workflows since I can’t right click a particular UI element and select it in explorer using the context menu.

Thanks for the report! This should now be resolved on a restart of Studio. Please let us know if that is not the case

5 Likes

Thanks, now everythings working :slight_smile:

2 Likes