ROBLOX Animation plugin bug (Incl. Solution)

When I tried to use the roblox plugin today I got this error:

14:22:27.059 - ServerScriptService is not a valid member of DataModel
14:22:27.061 - Script ‘Plugin_144373835.Plugin.AnimationEditor.MenuHandler’, Line 340 - local isPlaceSafe
14:22:27.063 - Script ‘Plugin_144373835.Plugin.AnimationEditor.MenuHandler’, Line 431 - field SelectRig
14:22:27.064 - Script ‘Plugin_144373835.Plugin.AnimationEditor’, Line 5688
14:22:27.066 - Stack End

The reason is I don’t name my ServerScriptService ‘ServerScriptService’, I name it ‘SService’ cause it’s shorter.

Solution: Use game:GetService(“ServerScriptService”) instead of game.ServerScriptService on line 340.

P.S. this is what variables are for

Writing local sservice = game.ServerScriptService in every script I write is very tedious not to mention unpractical.
Renaming it to SService is a perfectly good way of cleaning up your code.

The Name property of services isn’t read-only (we can edit them), so IMO CoreScripts and plugins should not rely on the services being named the default way. Especially because they can also call GetService.

I don’t have an opinion about renaming services as a developer being bad practice.

1 Like

You just got to hope you don’t rename something to another service.
And to be honest, I never knew this was a thing. None of my free models/scripts support this (including Nexus Admin).

game.Players for life

the moment I code game:GetService(“Players”) is the day I die


xD but that’s not what I ment.

Eitherway I think we derailed abit from the topic here.
There’s a bug in the animation plugin and I got a simple solution to it. Thats all.

For the record, I don’t use getservice either in my scripts. Cause I know what I named them.

Regardless of whether or not renaming services is weird (I personally think it’s bad practice, not sure why we allow this), the editor should be using GetService. Will patch this.

Edit: Oops meant to reply to OP