Roblox Animator throwing errors upon transforming certain limbs

Hello everyone,

I was working on some animations for one of my games when I encountered a significant problem:
When I tried to rotate and/or move certain limbs of the rig, Roblox Studio would send 2 different errors and not let me do anything.

The errors are the following:
Rig Error(s) detected
A model needs to have its parts joined together by Motor6Ds to properly animate.

Rig Error(s) detected
All the parts of this model are anchored, making it non-animatable. Please un-anchor the parts on this model.

Even though it said this, all the limbs were already connected with Motor6Ds (In fact, I used the Roblox “Create rig” button under Plugins to create the dummy) and I made sure nothing was anchored.

Here is a video showing the problem:

I have tried looking for other people having the same problem as me and anchoring / un-anchoring parts to make sure everything worked correctly, but nothing.

1 Like

someone reply pls :sob::pray:
I have the same problem