Roblox applications refuse to open on Windows

Since this morning (around 7am EST) I have been having issues with opening the Roblox client and joining games as well as editing in Studio. The reason why I have been taking my time to post this report is because I initially thought that it was due to me downloading some video games while at it.

What happens is that after pressing Play or Edit, the Roblox launcher does not show up as an application but a background process. When it does open normally and goes through the loading process, it doesn’t open the app for most of the time while the background processes are running but after a while those shut themselves off. There also seems to be a possible outage with the site as sometimes the homepage takes 2 refreshes to properly load in.

Steps to reproduce:

  • Open Roblox
  • Open your task manager
  • Try to join an experience or edit one
  • If the app doesn’t show up, scroll to your processes and look for any processes in relation to Roblox

The expected behavior here is that either the client or studio would open the experience. Actual behavior is it’s just not opening up properly.
Here’s a photo of Roblox Studio running only in the background

Reinstalling does not work. Studio actually gave me this error for the first time after doing so, so I suspect it’s just a broken update to the applications have been shipped:


So looks like the issue is fixed? Not sure honestly, if anyone’s still encountering the problem, please feel free to reply so the engineers can take a look at it


I can confirm weird behaviour with the client / studio, from yesterday, but it wasn’t the same as what you show. I had a HttpRequest error when trying to open it.

When trying to reinstall Roblox that fixed it, but even uninstalling was acting weird, it wouldn’t actually remove Roblox’s files, and I couldn’t delete some of them because they were “Open in System” as in the “System” process. It took some restarts to get it back working.

Edit: I do remember having some issues as well with the process staying there too as well as the system process thing I talked about.

1 Like

I have had this exact same problem yesterday night as well as ALL day. I tried restarting my computer, resetting the wifi, and running on administrator, but nothing would bother to work. I had this error when I tried to play a game. Studio had a different problem, but it’s similar to the comment above mine.



Hello, thanks for the report. I am unable to reproduce this issue on my end, everything works perfectly fine. Does the issue still occur on your side?

Nope. It was fixed about two to three hours later after posting this bug report.

I’m having the same issue as well

1 Like

I had this exact same issue but on Mac a while ago.

1 Like

As of now, I am also receiving this error. I was able to play games normally earlier today, so this bug is recent. I don’t want to jump to conclusions, however was the fix that was made earlier with the site being partially down have something to do with this?


1 Like

I can now confirm this is happening to me too on Windows. Studio refuses to launch with the exact same error.

1 Like

I’m having the same issue, I can’t even uninstall roblox or roblox studio without getting this error. Restarting my PC doesn’t fix it either.

I have been having the same exact issue, I started having this issue on 2021-06-23 at 12:30 PM (est). I know for a fact this is an API. This issue is one of the ones that come and go, I had it happen to me 2 times and after a couple minutes it goes away, and then in a day or so it comes back.



1 Like

Studio is back up for me.

I’ve also been having the same issue with launching both Roblox and Roblox studio. This happened to me on 6/24/2021 at around 6:25 PM EST. The error that kept on popping up when I try to launch the Roblox launcher went away in ~20 minutes, however my Roblox studio is still experiencing the same issue when I attempt to launch it.

Edit: My Roblox studio now works after reinstalling it.

I’ve had a similar issue occur to me as well. For anyone else still encountering this, a temporary solution that I’ve found was to disconnect & reconnect to your internet connection. Not sure if it works only for me but it’s still worth a shot.

To everyone above - your reports don’t seem to be part of what has happened to me. Please make a new report instead of plopping unrelated information into here and complicating the situation for the engineers.

1 Like

Sorry, to hijack your issue @ItsKoiske .

For those who are having the error “An error occurred while starting Roblox Details: HttpSendRequest failed” etc. Can you run the following from a command prompt?


It should give you back output like

Non-authoritative answer:


Also, can you check if you also get an error when just navigating your browser to ? The expected output should be just the JSON.

{ “message”: “OK” }

If you do get an error, sending back a screenshot of it would be helpful. You can DM me if you’d prefer for this or the output for the above nslookup command.

Hello, this is what happened to me when I clicked that link.

Though, when I just ran it anyways despite the warning, I did get that JSON message.

However, when I clicked the first link you sent I got that JSON. I also ran the command and got the output that you sent.

1 Like

So now I can join games and my roblox works properly. If this command was meant to fix it, thank you very much! I’m not sure if it was because of the command or if I got lucky, but hey at least it works now.