Roblox Client Crashing

Greetings, I ran into a problem where I was unable to play any Roblox games through the Roblox Windows Client (64-bit Version: version-893f07ad2be74f4d) about a week or two ago, it seemed to fix the same day after debugging it, only for it to return today.

I tried the same debugging strategy I had done previously and was unsuccessful. The Roblox Windows Client just seems to do its usual starting prompt, the prompt disappears, and then after a couple seconds, Roblox opens the game I tried to join… That should be it, but instead of that, a millisecond after Roblox opens the game, the application is instantly closed without an error or prompt being provided.

Upon investigating log files, it seems to get stuck at a point where it’s trying to re-size for my primary monitor’s screen resolution. I haven’t found any errors, warnings, or info from it in Event Viewer. It also doesn’t appear to be in the background.

The methods of debugging I’ve tried includes restarting my PC, making sure Windows is up-to-date, making sure my drivers are up-to-date, ensuring my graphics card and its drivers are fine and up-to-date; as well as uninstalling Roblox completely and re-installing it. I have also tried using Disk Cleaner to remove Temporary Files and Thumbnail Files on my System Drive (C:) which has the Roblox Windows Client installed on it, as some have said that tends to fix the problem. Only this time it didn’t.

My PC Specs
OS - Microsoft Windows 11 Home - Version 10.0.22621 Build 22621
CPU - 11th Gen Intel(R) Core™ i7-11700F @ 2.50GHz
RAM - 32 GB
GPU - NVIDIA GeForce RTX 3060 Ti

I have also tried using other browsers to launch the Roblox Windows Client and had the same result.

I’m not quite sure what the exact cause of the problem is, I’ve been told it is a software conflict, or graphics card related error, but I am still uncertain and looking for an exact answer and a solution for it. If anyone has any info on this, please reach out and let me know, thanks!

Attached below is a video of the problem at hand:

Update (10/28/2023): I found a few posts with the exact same issue, one of them pointed at the software “Logitech G Hub” as for some people, uninstalling it has fixed the issue… I attempted this today, and I am still having the same problem… Even after restarting my device, and also reinstalling roblox.

The post regarding Logitech G Hub causing the Roblox Windows Client to crash can be found here if it fixes this issue for any of you.

1 Like

it seems to be an issue with this build of Roblox.
other people have been experiencing this issue too.
i haven’t found any fixes though i will keep looking

Just found the solution to my crashing problem in another post, a user described having this same issue only while they had a G29 Logitech Steering Wheel connected to their computer. I had one connected, when I unplugged it and tried joining a game on Roblox, the issue was resolved…

This is where that was found:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.