Roblox client freezes at launch - blank screen and Roblox logo does not rotate

Whenever I want to join a game, my Roblox client freezes when I want to enter any game.

The roblox logo doesn’t even rotate. I checked the Task Manager if the game isn’t responding but it doesn’t even say that. I expect from the client to run and proceed to the game.

This happens about 90% of the time. This also happens if the game wants to teleport me to another place.

This bug kept occurring after reinstalling Roblox. I have checked if it was my internet. No problems.

Here is the relevant portion of my log file:

1587748957.47902,2354,6 PlaceLauncher URL :
1587748978.55298,2354,6 Placeluancer.ashx exception:[HttpError: ConnectFail]
1587748978.55298,2354,6 Error: PlaceLauncher: Exception thrown: Can't join place 292439477, because HttpError: ConnectFail
1587748978.55398,2354,6 Error: in handleGameStartFailure, msg is GameStartFailureOthers

log_004B3_1.txt (3.0 KB)
I have dump files available upon request.

Here’s my PC information:

  • Windows 10 Home,
  • Intel Xeon X5450 @ 3.00 GHz,
  • Nvidia GTX 1050Ti 4GB,
  • 6GB of installed memory,
  • WD2500 265GB HDD.

I just experienced this in Studio by play-testing solo, I quit the app to reopen it but now it’s non-responsive and I cannot force quit it. I don’t want to, but I may have to restart my computer just to fix this as I can neither reopen nor quit Studio.

Edit: I’m still experiencing this, I’m not sure if this helps but I did get this error in one instance:

Error checking in group: Player:IsInGroup failed because HTTP unknown error (HttpError: curl:52, Server returned nothing (no headers, no data))

1 Like

Pretty sure this is an internet connection issue. I have had this happen before.

This could be a server connection issue or due to a roblox security issue with player exploits. I haven’t gotten the blank screen before, but there are scripts that allow players to shut down games and if a player is trying to join the server they just shut down, it will give them a screen such as yours. I suggest restarting your modem/router first, restart your PC and clean it for harmful files or viruses, and then try it again. If you’re still having problems, DM me, and I will assist you within the best of my ability.

This has been happening to me for the past 3-5 hours. It doesn’t matter how I attempt to join a game, whether it be via the play button, or joining a specific server. I’m usually left in limbo on the blank screen. However, it is worth mentioning, this happens everytime when trying to join a specific server instance. Such as joining a friend directly, or a server from the server list. When it comes to joining via the play button, it happens roughly 1/4 times.


Happened for me since yesterday, it happens about 50% of the time.

This happens regularly to me, however, after attempting to join another server on the same game the issue doesn’t occur. I know it’s not my internet connection as I can run a speed test and or be connected to another service or game at the same time.

Main thing I always notice is that the Roblox logo won’t spin and the game’s name won’t pop up, after that I just close the Roblox process and attempt to join again. The problem can happen multiple times in succession. The issue has occurred before when teleporting.


I’ve seen this issue being reported frequently by players of a place I work on, usually when attempting to join the first/most populated server. The issue has only started happening recently. Players say that the issue predominantly happens on that game only, but so far I’ve been unable to track down the source of this problem.

Could StreamingEnabled be a factor, or perhaps a regional issue? A majority of my players are from Malaysia.


This is most likely a regional issue, this happens every time I create a server in either Australia or New Zealand, this has been affecting me for a week now.

This has been happening to me for the past week. This happened in a place that @yan3321 mentioned, Kuala Lumpur, Malaysia. I played the game normally as usual and this week I am unable to join the game. This is what happens if I join the game.

I asked some people and one person said to fix this problem, disable the firewall. I tried this and it didn’t work. I tried this alongside with a VPN, nothing works.

One person said he’s from Singapore, and he said last week, no one from Singapore can join any Roblox games, but this week they can.

During a “big day” (some event), 5 individuals can’t join a 23/200-player server.

I am from Indonesia, near the capital city, Jakarta. This bug usually happens when I try to join a specific server, a crowded server (specifically from 15-30 players), around the first to third server. This might possibly be a regional problem.

Hope this can be fixed, I am seriously irritated with this bug, ESPECIALLY WHEN IT HAPPENED FOR 5 DAYS STRAIGHT.

first time writing a post, if im wrong with the etiquettes and such, much apologies thanks


This was also happening to me every time I tried to join someone that is in Austrillia and another person that is in New Zealand, but just recently I have been able to join them. Roblox may have just fixed this bug but I’m not too sure.

1 Like