Website is being extremely slow/not loading on my connection in Asia

Sorry if this isnt a proper format or the proper topic.

Recently (about a week ago) ive been experiencing a lack of performance from the website. It was taking longer than usual for the website to load. I was able to get by, but about this morning is when things were coming to a point where the website is just unusable (by this morning i mean about 13 hours before this post is up).

I left this up for about 5 minutes and it shows no sign of progress of anything loading:

I did check my internet connection before this, i can open up other websites with ease but i cant open roblox. Most of the time when i try to open it my browser will have error messages saying “roblox.com took too long to respond”, “roblox.com didnt send any data” etc. And the times when i do get in the website it just loads infinitely like the image above. I cant edit any games or play any games because i dont even have access to the website

My friends are saying their website is fine so im wondering if there are any other people who are experiencing the same issue as me right now or is this depending on which region i am? Other roblox websites seem to work fine (Devforum and developer.roblox).

My region is Asia (South East Asia)

8 Likes

Sometime the problem is on the WiFi or on the GB.

Indeed. I think my ISP isn’t performing as efficiently for collecting robloxs data. Some other websites are also down when this happens (Twitter, Pixiv, etc).

1 Like

I’ve also had this issue a week back or so and I also live in Southeast Asia. I tried reinstalling Roblox, restarting my router and doing all the tips Roblox provided to no avail. Other websites unrelated to Roblox worked perfectly fine for me. Eventually this issue fixed itself for me and I’m currently able to play Roblox and use Studio normally.

While I encountered this issue I also encountered blank loading screens on Roblox Player and Studio took an awfully long time to load before it disconnected itself, regardless of whatever game it was. This post and another one might be relevant to you.

My best guess is that the server is somehow struggling to connect to the client. Regional issues perhaps? The least you could do is wait it out like I did; I believe that the issue should resolve itself in time to come.