Roblox Crashes on Startup, Happens on Random Timing

Oh, Sorry the topic was a bit old and rarely someone replies so rather than than I post some possible solutions for this (which wouldn’t work with everyone) I private messaged him with some solutions, anyway

The method that worked is updating the Graphics card drivers, How:
Win 10: Open Windows updates and click ‘other updates’ and select graphic (monitor) drivers to update them
Win 10 and below: open device manager then select graphic card and then right click it and then choose ‘update drivers’

7 Likes

I know this post is old, but I am experiencing the exact same thing.

100% of the time when I try to launch either Roblox Studio or Roblox Player, I get this error message:
image

I’ve uninstalled and re-installed Roblox multiple times, deleted Roblox files from the registry, %appdata% and %localappdata%, allowed through firewall, etc. This error happens always.

I thought it might be some other internal error, so I factory reset my laptop. Roblox Studio ran perfectly once and the error started happening again.

I’ve been dealing with this issue for around 1 month now, I’ve looked through every post and articles I could find and none have helped me, and luckily I’ve stumbled upon this one. Trying it on another user works, but it breaks again over time.

1 Like

Try installing Direct X, Visual C++ and .NET 4.8, also make sure your pc is up to date

1 Like

Did that, still instantly crashing. I have all my GPU Drivers. It is working on the Microsoft Store version but no one uses that ugly slow mess. Any more tips? I start loosing hope in roblox

Unfortunately, still crashes. :confused:

Try re-installing your graphic card drivers, also check this and reinstall Roblox.
@Rezault try updating your GPU drivers if they aren’t or downgrading them if they’re.

Did that 3 times. This is some kind of issue on roblox’s end… Seems that this is happens on multiple computers with the same hardware (I5 10400, RTX 3060 TI, 16GB RAM 2666mhz)

The best you can do for your GPU is to disable V-sync and image sharpening, Oh and also enable Max performance in power management.
If nothing works then turn off your firewall and antivirus or change your GPU.

Yeah, the post is old, and stuff, but I have the (almost) exact same problem.

All of the time, when I try to launch Roblox, it instantly crashes, without any error message, as shown in the gif below.

However, Roblox Studio and the Microsoft Store version (garbage, ew) work perfectly fine.

I have tried all the solutions written in this topic: they were temporary fixes - launch Roblox for the first time with the solution: works, launch Roblox for second time: crashes.
Does anyone know a fix that’s hopefully permanent?

1 Like

For me it doest even load the green bar. Instantly crashes.

Yeah. It needs to be taken down. If you put it in the bar it kicks you for not having ethernet…

I have wired ethernet.

Specs:

CPU - I5 10400
PSU - Gamemax VP-800-RGB-M, 80+ Bronze, 800W
GPU - NVIDIA 3060 TI
RAM - G.Skill 16 GB 2666 MHZ
2.5 gig realtek network card
Wired 1 gig cat5e cable

I have overclocked the system. Happens with it not overclocked at all.

Here are some random logs I found:

2021-08-09T08:55:20.079Z,0.079931,5044,6 [FLog::Output] RobloxGitHash: 6b39d48586ccacb69fa54839a4ea9aa327fecc10
2021-08-09T08:55:20.080Z,0.080931,5044,6 [FLog::Output] The channel is production
2021-08-09T08:55:20.413Z,0.413819,5044,6 [FLog::Error] Dynamic initializer test result: FAILURE
2021-08-09T08:55:20.414Z,0.414822,5044,6 [FLog::LocalStorage] LocalStorage loading from path: C:\Users\bloxx\AppData\Local\Roblox\LocalStorage\appStorage.json
2021-08-09T08:55:20.414Z,0.414822,5044,6 [FLog::Output] TaskSchedulerMk2::applyAsyncTaskThreadCount( 4 ) <req: 0 active: 0>
2021-08-09T08:55:20.432Z,0.432875,45c4,6 [FLog::LocalStorage] LocalStorage loading data: {“AppInstallationId”:“8076098739216262562”,“BrowserTrackerId”:“114323285937”,“PolicyServiceHttpResponse”:"{“isSubjectToChinaPolicies”:false,“arePaidRandomItemsRestricted”:false,“isPaidItemTradingAllowed”:true,“allowedExternalLinkReferences”:[“Discord”,“YouTube”,“Twitch”,“Facebook”]}",“AppConfiguration”:"{“GUAC:2478497458:app-policy”:"{\“ChatConversationHeaderGroupDetails\”:true,\“ChatHeaderSearch\”:true,\“ChatHeaderCreateChatGroup\”:true,\“ChatHeaderHomeButton\”:false,\“ChatHeaderNotifications\”:true,\“ChatPlayTogether\”:true,\“ChatShareGameToChatFromChat\”:true,\“ChatTapConversationThumbnail\”:true,\“GamesDropDownList\”:true,\“GameDetailsMorePage\”:true,\“GameDetailsShowGlobalCounters\”:true,\“GameDetailsSubtitle\”:true,\“GameInfoList\”:true,\“GameInfoListDeveloper\”:true,\“GamePlaysAndRatings\”:true,\“Notifications\”:true,\"Recommende
2021-08-09T08:55:20.432Z,0.432875,5044,6 [FLog::Output] TaskSchedulerMk2::applyAsyncTaskThreadCount( 4 ) <req: 4 active: 4>
2021-08-09T08:55:20.433Z,0.433878,5044,6 [FLog::LocalStorage] LocalStorage loading from path: C:\Users\bloxx\AppData\Local\Roblox\LocalStorage\memProfStorage17672.json
2021-08-09T08:55:20.449Z,0.449925,45c4,6 [FLog::LocalStorage] LocalStorage failed to load: C:\Users\bloxx\AppData\Local\Roblox\LocalStorage\memProfStorage17672.json
2021-08-09T08:55:20.499Z,0.499306,5044,6 [FLog::Output] Loading AppSettings.xml from C:\Users\bloxx\AppData\Local\Roblox\Versions\version-f193a9f948264479\AppSettings.xml
2021-08-09T08:55:20.500Z,0.500303,5044,6 [FLog::Output] setAssetFolder content
2021-08-09T08:55:20.502Z,0.502297,5044,6 [FLog::Output] setExtraAssetFolder C:/Users\bloxx\AppData\Local\Roblox\Versions\version-f193a9f948264479\ExtraContent
2021-08-09T08:55:20.504Z,0.504291,5044,6 [FLog::Output] CrashReporter Start
2021-08-09T08:55:20.504Z,0.504291,5044,6 [FLog::Output] The crash upload percentage is 10
2021-08-09T08:55:20.504Z,0.504291,5044,6 [FLog::Output] Info: Searching for and uploading crash dumps
2021-08-09T08:55:20.504Z,0.504291,5044,6 [FLog::Output] the dump url:
2021-08-09T08:55:20.504Z,0.504291,24d8,6 [FLog::Output] WatcherThread Started

From the logs I was thinking that only 1 Core was active, however it appears that all 6 are active and used in task manager.

Atleast now I Know that that task uses 2 cores.

1 Like

Didn’t help. I’m very confused as to what’s causing this issue. :confused:

Hello, I know this is an old topic. But now the Windows Roblox app just doesnt open.
It immediately closes itself right as it shows the ROBLOX logo

Any updates on this? It’s still happening :confused: