Roblox Crashes on Startup, Happens on Random Timing

Problem:
Since June 12th, 2020, the Roblox App I have has started to crash on start up. The update process while launcher.exe is running works fine, however, as soon as the launcher closes I am greeted with Crash message. I have followed the steps on https://en.help.roblox.com/hc/en-us/articles/203312980-How-to-Uninstall-Roblox to completely uninstall the app, however, it still will start crashing once installed. The only way to fix this I found so far was to get rid of windows account I am on, and create a completely new account. However, the same crash will start again after few play sessions.

Reproduction Steps:
I am not entirely sure how to reproduce this as it can occur on any timing. However, I once made this situation when I closes the process of roblox from task manager.

Crash Log and Dump:
https://devforum.roblox.com/t/log-and-dump-file-of-roblox-client-crash-report/628559

Video:

(Edit)
Both my windows profile nor roblox directory had a non-alphanumeric characters.

(Edit2)
Last 20-40 Lines of Log file

1592825376.63779,2c28,6 Loading AppSettings.xml from C:\Users\Dev\AppData\Local\Roblox\Versions\version-26fc3239eb174834\AppSettings.xml
1592825376.63878,2c28,6 setAssetFolder content
1592825376.64178,2c28,6 setExtraAssetFolder C:/Users\Dev\AppData\Local\Roblox\Versions\version-26fc3239eb174834\ExtraContent
1592825378.86950,2c28,6 CrashReporter Start
1592825378.88159,3374,6 WatcherThread Started
1592825379.26774,2c28,6 Info: Initializing new game
1592825379.27772,2c28,6 account = UA-43420590-14, schedule = 500
1592825379.28569,2c28,6 LocalStorage loading from path: C:\Users\Dev\AppData\Local\Roblox\LocalStorage\appStorage.json
1592825379.29767,07c4,6 LocalStorage loading data: {“BrowserTrackerId”:“56395989560”,“AppConfiguration”:"{“GUAC:527353454:app-policy”:"{\“ChatConversationHeaderGroupDetails\”:true,\“ChatHeaderSearch\”:true,\“ChatHeaderCreateChatGroup\”:true,\“ChatHeaderHomeButton\”:false,\“ChatHeaderNotifications\”:true,\“ChatPlayTogether\”:true,\“ChatShareGameToChatFromChat\”:true,\“ChatTapConversationThumbnail\”:true,\“GamesDropDownList\”:true,\“GameDetailsMorePage\”:true,\“GameDetailsSubtitle\”:true,\“GameInfoList\”:true,\“GameInfoListDeveloper\”:true,\“GamePlaysAndRatings\”:true,\“Notifications\”:true,\“RecommendedGames\”:true,\“SearchBar\”:true,\“MorePageType\”:\“More\”,\“AboutPageType\”:\“About\”,\“FriendFinder\”:true,\“SocialLinks\”:true,\“SiteMessageBanner\”:true,\“UseWidthBasedFormFactorRule\”:false,\“UseHomePageWithAvatarAndPanel\”:false,\“UseBottomBar\”:true,\“AvatarHeaderIcon\”:"LuaApp/icons/ic-b
1592825380.50987,2c28,6 D3D11 Adapter: Intel® HD Graphics 610
1592825380.50987,2c28,6 D3D11 Adapter: Vendor 8086 Device 5906 VRAM 128 RAM 3967
1592825380.50987,2c28,6 Caps: ThreadSafe 0 Framebuffer 1 FpFramebuffer 1 Shaders 1 Compute 1 Instancing 1 ConstBuffers 1
1592825380.50987,2c28,6 Caps: Framebuffer: MRT 8 MSAA 16 Stencil 1
1592825380.50987,2c28,6 Caps: Framebuffer: Depth16 1 Depth24 1 DepthFloat 1 DepthClamp 1
1592825380.50987,2c28,6 Caps: Texture: RGB10A2 1 RG11B10F 1
1592825380.50987,2c28,6 Caps: Texture: DXT 1 PVR 0 ETC1 0 ETC2 0 Half 1
1592825380.50987,2c28,6 Caps: Texture: 3D 1 Array 1 Depth 1 MSAA 1 MSAAFP16 0
1592825380.50987,2c28,6 Caps: Texture: NPOT 1 PartialMips 1 CubeMipGen 1 CubeFramebuffer 1
1592825380.51087,2c28,6 Caps: Texture: Size 16384 Units 16
1592825380.51087,2c28,6 Caps: ConstantBufferSize 65536
1592825380.51087,2c28,6 Caps: 32bIdx 1 Memoryless 0
1592825380.51087,2c28,6 Caps: ColorBGR 0 HalfPixelOffset 0 RTFlip 0 MinusOneToOneDepth 0
1592825380.51087,2c28,6 Video memory size: 2147483648
1592825381.10763,3374,6 Info: StartProcessException…
1592825381.15467,3374,6 Studio D3D9 GPU: Intel® HD Graphics 610
1592825381.15567,3374,6 Studio D3D9 GPU: Vendor 8086 Device 5906
1592825381.15567,3374,6 Studio D3D9 Driver: igdumdim32.dll 27.20.100.8280
1592825381.15767,3374,6 ESGamePerfMonitor GPU: Vendor 00008086 Device 00005906
1592825381.15767,3374,6 ESGamePerfMonitor GPU: SubSys 8377103c Revision 00000002
1592825381.15767,3374,6 ESGamePerfMonitor GPU: DedicatedVidMem 134217728 DedicatedSysMem 4160684032 SharedSystemMemory 201824035112222720
1592825384.12615,3374,6 Info: Uploading crash analytics…
1592825384.12715,3374,6 Info: Done uploading crash analytics
1592825384.21408,3374,6 Info: WatcherThread Exiting.

The log file above was inside archive folder of logs, however, there also is a log file outside of archive file:

1592825385.43147,3d64,6 Loading AppSettings.xml from C:\Users\Dev\AppData\Local\Roblox\Versions\version-26fc3239eb174834\AppSettings.xml
1592825385.43546,3d64,6 setAssetFolder content
1592825385.43746,3d64,6 setExtraAssetFolder C:/Users\Dev\AppData\Local\Roblox\Versions\version-26fc3239eb174834\ExtraContent
1592825385.43845,3d64,6 CrashReporter Start
1592825385.43945,3e10,6 WatcherThread Started
1592825385.43945,3d64,6 Info: Searching for and uploading crash dumps

13 Likes

Hello, I have that same exact problem. I uninstalled roblox and reinstalled it multiple times. I even deleted the registry keys and any thing that is related but nothing happened. If you found a way of fixing this could you please tell me. Ive been having this problem for 2 weeks now.

3 Likes

Unfortunately, I have no idea how to fix this. For me, the problem seemed to have stopped after 3-4 weeks? and has since worked as intended. I am not sure of how I delete registry keys, so I don’t think deleting it would work. (Unless deleting and creating a new windows local account does that, which is what i did)

Ok, thanks for the info. Ill try that later.

Hello, I have had this exact same issue for a few months and nothing has fixed it. the only way i could find of fixing it is to use the Win10 app which is not convenient to use and there is a bug with the full screen not working after joining a game and leaving it (I cant post on bug reports yet)

@Bluebookltd @Yuuwa0519 @TheLegendOfSirenhead
Double check that you have enough available memory, you may just be running out. Try joining an empty baseplate and see if you crash.

As for everything else, here’s a post I just now made detailing how to reset Roblox without resetting your settings.
(Also, creating a new Windows account technically did everything there but I’d honestly not recommend doing that unless nothing else works)

1 Like

I have tried on another machine and it is fine and im able to run more intense games on my 8gb of ram fine so that shouldnt be an issue it just broke

Check in Task Manager if you are running out of RAM when you run the game, the amount of RAM you use on one PC might be different than another because different drivers, programs, services, etc might be running, and some might be using more RAM because of different configurations or hardware, etc. If you have 2 GB free and Roblox reaches 1 GB or more right before the crash, it might be related to memory. Generally, you want to make sure you have like 1 GB free because Roblox will trigger a crash if it detects that a small amount of RAM is available to it.

Additionally, try joining on an empty baseplate like I suggested and see if you crash. If you don’t crash when joining an empty baseplate, its likely due to memory usage and not anything else like a corrupt install.

Thirdly, try resetting Roblox related stuff that could be causing that like I explained in the post I mentioned, if its a corrupt installation, going through everything there should absolutely fix your issue.

I see what you mean but im able to join on the Win10 app at max graphics settings on random games and i cant even join a blank baseplate on the normal client because it crashes before it loads anything and after the launcher opens and starts the player Here is the latest log

1602978480.04148,3738,6 The channel is NULL
1602978480.36222,3738,6 TaskSchedulerMk2::applyAsyncTaskThreadCount( 4 ) <req: 0 active: 0>
1602978480.36623,3738,6 TaskSchedulerMk2::applyAsyncTaskThreadCount( 4 ) <req: 4 active: 4>
1602978480.38728,3738,6 Loading AppSettings.xml from C:\Users\MyUser\AppData\Local\Roblox\Versions\version-d25d44458f014535\AppSettings.xml
1602978480.38828,3738,6 setAssetFolder content
1602978480.38928,3738,6 setExtraAssetFolder C:/Users\MyUser\AppData\Local\Roblox\Versions\version-d25d44458f014535\ExtraContent
1602978480.38928,3738,6 CrashReporter Start
1602978480.39029,3738,6 Info: Searching for and uploading crash dumps
1602978480.39029,0a94,6 WatcherThread Started

I didn’t think it was related to memory in the first place, I am just trying to rule out possibilities with you.

Based on the logs provided by multiple people it looks like the crashing might be related. According to Yuuwa creating a new Windows user fixed the issue which would imply a corrupt install of some kind. Maybe try creating a new Windows user and seeing if that works. If that’s the case, its again gotta be something related to the registry or some Roblox files.

Ok, I did your reset steps and now you told me to try it on another user it works on the other user even though it didnt before and i did the steps on my main windows user. The windows user it started to work on was made before this started happening and im confused on how thats broken
Also ive tried wiping all of my roblox files and on my main user but i just did a casual uninstall and reinstall on the other user and studio works and i deleted the registry in your tutorial you said to delete