Roblox defaulting to use Occulus Rift for audio output instead of my default speaker

This occurs both in game and in studio. I’m on Windows 10. As you can see here Occulus is not my default sound device

image
image

I usually keep roblox muted anyways but I went to add audio to my game and began getting more and more frustrated when no matter what I did I couldn’t hear any of the audio I’ve been scripting. And then I noticed it was playing from somewhere else in my room, and wha-la. Everything else on my computer plays through the correct device and as far as I can tell I can’t find any way to switch it for roblox specifically.

9 Likes

I just keep my rift audio disabled until I need it. That’s the only work around I know.

5 Likes

Oh hey that helps. It’s not ideal but at least I can hear studio now.

1 Like

This happens on my Vive

On the Vive, the VR software is responsible for controlling which audio device is used. This may be the same with Oculus as well – check its settings to see if anything’s there.

I also had this problem, what I had to do was change SteamVR settings so that they didn’t mess with my audio inputs and outputs, and instead only mirrored the audio. Now it looks like this:

“Focusrite USB” should be whatever audio device you want to use. You can also set it to not change the audio device at all, but I had some issues with that where it would sometimes still change.

Was just about to report this.
ROBLOX should really be using the default audio device.
I have Oculus Tray Tool/SteamVR change my default audio device to my Oculus headset when I intend to use it. I shouldn’t have to disable the Rift headphones exclusively for Roblox.

3 Likes

I’ve been having this issue as well, even if I entirely disable the oculus service it still plays through my rift headphones. (which are broken anyways)

I have VR mode turned off and oculus service disabled, however it still doesn’t play through my default device. It only works if I entirely unplug my headset, but I have other people who use the headset and I don’t want to have to constantly plug/unplug my headset.

2 Likes

This is happening for me as well. Current workaround is to entirely disable my rift headphones.
This doesn’t happen with any other games/software I’ve used, so it’s not likely to be an issue with my settings in the Oculus app (it still happens when I close the oculus service entirely).

Would be great to have a fix as this is a pain and slows down VR dev workflows.

1 Like

It’s 2021, and it’s still an issue somehow