ROBLOX Developer Portal - Mobile Search broken

  • Describe the bug. Describe what is happening when the bug occurs. Describe what you would normally expect to occur.

The bug occurs on robloxdev.com. When you visit the website on a mobile phone, and try to press the search icon the search bar opens and closes immediately

  • How often does the bug happen (Everytime/sometimes/rarely)? What are the steps that reproduce the bug? Please list them in very high detail. Provide simple example places that exhibit the bug and provide description of what you believe should be the behavior.

The bug happens all the time.

Steps to reproduce:

  • Visit the website on a mobile phone
  • Go to the header and press the search icon
  • Where does the bug happen (www, gametest, etc) Is it level-specific? Is it game specific? Please post a link to the place that exhibits the issue.

robloxdev.com (All pages)

  • Anything else that you would want to know about the bug if it were your job to find and fix it.

Tested on Samsung Galaxy S7, Chrome version 67.0.3396.87, Android 8.0.0
Tested on Samsung Galaxy S7, Samsung Internet

6 Likes

@CloneTrooper1019, perhaps you can do something with this (no idea or the web team is responsible or the IX team)

I also had this problem. I had to use desktop view.

Ditto
Same chrome version on a Pixel XL.

When I tried to search something on the DevHub by tapping on the search icon using my android device, the keyboard pops up but a split second later it disappears. I can keep tapping the icon and the keyboard pops up every time, but it disappears immediately afterwards.

This happens 100% of the time, even after refreshing and deleting cookies.

I do not know when the bug started happening, but I do remember experiencing it around the time the DevHub initially released.

I’m running a Pixel 2 XL with Android 9.0 (latest update as of 11/5/18)

1 Like

Hey Locard, could you check again for me? I just fixed an issue that was breaking search on developer.roblox.com

Just cleared cache and everything but my keyboard still doesn’t seem to stay appearing unfortunately.

Running a first gen Pixel with exact same results. I used to be able to get around it by requesting the desktop site, but that search script is being barred from being loaded over http, and chrome mobile doesn’t give me a button to load it anyway. So I straight up can’t search the devhub on mobile rn.

The script over http issue is a thread here btw:

I’m sorry for the bump, but this issue still happens. Any plans to actually fix it?

Can confirm search doesn’t work for me on mobile, super annoying as I have to switch to desktop mode every time (rather ironic lol)

3 Likes

Can also confirm. This is really disruptive to my work flow when I use my phone to refer to docs while developing :slightly_frowning_face:

I can say for me, I do not have this problem. I am on a IPhone 7.

I don’t use the search at all, cause I know I won’t be able to search anything using it.
I use Google instead.
I would really love to be able to use DevHub without leaving DevHub.

1 Like

Still broken. It works in the fake mobile view from the Chrome dev tools, but not on actual Chrome browser on a phone.

This bug is approaching its 1-year anniversary.

3 Likes

This happens for me on Chrome, but on firefox the keyboard stays up so I can just tap search a second time and it works. Definitely a bug though.

Apologies for the 1-year long period of us addressing the bug! It’s certainly been on our radar and I can’t make any promises but we will get to it as soon as possible, especially noting that some of you use the site on mobile.

6 Likes