Roblox doesn't respect the windows mouse sensitivity setting

I’m on windows 8.

I recently got a gaming mouse that allows me to change the DPI. Because I like precision, I set the windows mouse sensitivity all the way to the lowest setting and raised my mouse’s DPI. It works fine with every application except roblox. In roblox, my mouse moves much faster than it normally does, regardless of what my pointer speed is set to, in both third-person and first-person.

My mouse is a Steelseries Sensei and my DPI is set to 6000. Please fix.

1 Like

Does going into ROBLOX Studio -> Settings -> Game Options -> And enabling “HardwareMouse” change anything?

I can’t test it right now, as I’m not on my PC which has my DPI-adjustable mouse. :frowning:
That’s the only thing I could think of, that might make a difference.

In reality, ROBLOX’s mouse options are basically non-existent.

1 Like

[quote] Does going into ROBLOX Studio -> Settings -> Game Options -> And enabling “HardwareMouse” change anything?

I can’t test it right now, as I’m not on my PC which has my DPI-adjustable mouse. :frowning:
That’s the only thing I could think of, that might make a difference.

In reality, ROBLOX’s mouse options are basically non-existent. [/quote]

That doesn’t change anything, unfortunately.

Darn, that’s unfortunate.
Let’s hope they add some sensitivity bar into the game somewhere, this is one of those things that it seems we just have to live with.

Odd, I run windows 8 and my mouse sensitivity works.
It could be due to the fact that I change the sensitivity via a button on the mouse itself.

[quote] Odd, I run windows 8 and my mouse sensitivity works.
It could be due to the fact that I change the sensitivity via a button on the mouse itself. [/quote]
Yeah, if you lower the DPI setting, you will find a setting that ROBLOX works with.

The problem here (as I understand it), is that when you use a high DPI mouse setting with a low Windows mouse sensitivity, the mouse sensitivity in ROBLOX is responding to the mouse’s DPI setting and completely ignoring the Windows mouse sensitivity setting.

I’ve been waiting for this bug to have been reported, I forgot to do it myself.

It’s true, ROBLOX ignores the Windows sensitivity and has it stuck at their custom sensitivity.

If I want to play games properly, I have to switch to 1600 DPI, when I’m normally at 3200 DPI.

I switch using a button on my mouse, of course. Hardware DPI settings are better than software DPI settings.

[quote] I’ve been waiting for this bug to have been reported, I forgot to do it myself.

It’s true, ROBLOX ignores the Windows sensitivity and has it stuck at their custom sensitivity.

If I want to play games properly, I have to switch to 1600 DPI, when I’m normally at 3200 DPI.

I switch using a button on my mouse, of course. Hardware DPI settings are better than software DPI settings. [/quote]

Pretty much this. When I play roblox, I have to switch from 3600 DPI to 1200, and it’s not fun, as my mouse will be slow, whe I hover it to my second monitor, while playing.

[quote] I’ve been waiting for this bug to have been reported, I forgot to do it myself.

It’s true, ROBLOX ignores the Windows sensitivity and has it stuck at their custom sensitivity.

If I want to play games properly, I have to switch to 1600 DPI, when I’m normally at 3200 DPI.

I switch using a button on my mouse, of course. Hardware DPI settings are better than software DPI settings. [/quote]

Pretty much this. When I play roblox, I have to switch from 3600 DPI to 1200, and it’s not fun, as my mouse will be slow, whe I hover it to my second monitor, while playing.[/quote]
Exactly. It’s soooooo irritating.

This is more of an idea. Since ROBLOX has it’s custom sensitivity setting, they should add a sensitivity changer or remove their custom sensitivity setting.

It’s not that roblox is using their own sensitivity setting, it’s that it’s simply not respecting the windows sensitivity setting.

Oh, if that’s the case, then ROBLOX should fix this. But they should add their own sensitivity bar hidden deep down in their options menu as well.

Sorry for the extreme necropost, but since the new updates in studio, I’m having troubles with my mouse sensitivity as well.

Is there a way to change the mouse sensitivity in studio (not in Roblox) because it seems like the new Studio update with HTTP permissions and API keys caused this problem. Roblox might have updated the sensitivity without telling anyone about it.

Right now, I can’t accurately build models in studio without having my mouse going crazy and I’ve never had this problem before.