Roblox doesn't work?

Imma get straight into the issue, one month ago, I was playing Roblox normally, then suddenly the next day i tried opening it again (just chose any game and pressed “play”)

The roblox update window popped up and I thought it was a roblox update just like any other
To my suprise tho, The download bar increases a bit then suddenly stops at the middle of it (image)


It’s been like this for a month now, everytime I try to open roblox on the web.
I have tried uninstalling roblox many times and in various ways but none worked.

(the same exact thing happens with Roblox Studio)

If you have any idea how to fix this please let me know, I really need to get back to developing

Try checking your desktop’s firewall. I would recommend looking into this Roblox support article.

TLDR: You need to allow Roblox to go through your Firewall. Try checking the application’s inbound rules. It could possibly be the IP as well .

Your firewall probably has Roblox on blacklist.

I checked the link you sent idk if im doing it wrong but I think its already allowed

Still roblox doesnt want to install