Roblox either not launching or launching slowly

Been having a strange issue with Roblox for around a week where trying to launch it from the website or app takes significantly longer than usual, or just straight up doesn’t launch and sits as a background process.

It’d take a second for Roblox/Bloxstrap to open a game from website, however following an update from Roblox when I tried to play a game, the game client window didn’t pop up. I sat for a good several seconds waiting, then ultimately gave up and just task ended it. It took another try or two until it finally launched for real.

No clue how or why this started occurring. When I check Task Manager, it starts around 15% CPU before lowering down to 11-12% CPU for a while, deciding whether it wants to work or not. When it ACTUALLY launches, it’ll quickly reach 18-20% CPU and then the window will finally appear.

I’ve tried uninstalling and reinstalling both Roblox and Bloxstrap, doublechecking Firewall, allowing each related program to run as administrator, none of which have fixed it. I don’t have RTSS or MSI Afterburner, nor do I believe it could be an internet issue. I do have the BTRoblox and RoPro extensions enabled, though it wouldn’t explain why it’s happening to the app as well.

These are my specs if it helps:
Windows 11 Home 10.0.22631
x64-based PC
AMD Ryzen 5 5600X 6-Core Processor

Roblox thankfully still works and runs like it always does in-game (loading times between joining games has gotten longer too but whatever) but it’s annoying just sitting and waiting to see if it’ll actually open.


okay so just learned apparently the roblox player shortcut on my desktop is likely 32-bit since it’s from my program files (x86) folder, yet bloxstrap is 64-bit in my appdata folder so dunno if that has anything to do with it. also the only roblox version folder in appdata had a single robloxplayerlauncher and running it just. deleted itself lol?? btw roblox DOES end up launching after several minutes

I’m completely unable to launch Roblox from the website. It all started bc I tried to reinstall to fix a double startup issues.

I can still launch manually from the windows app, but like its the windows app and all so.


I also encountered a launching issue on the Roblox website and Roblox Studio, but I received the available update from Roblox and everything worked. Just wait, it could also be a compatibility issue. Wait for a technician to submit the ticket here and it will work again. That’s how I proceeded.

1 Like

i’ve received a few updates from roblox as i haven’t found a fix for the issue, and none of the updates seem to have actually worked. roblox still takes likes half a minute or longer to open and still rarely hangs in the background when i try to run it. honestly i’ve just been living with this for a while the best i can despite how loading into certain games can take. stupidly longer than how it used to

ok uh! my problem fixed itself somehow when i opened my pc today, it actually opened very quickly and i even tested multiple times to see if it’d work for real on both website and app and yea it had fixed itself hurray yippee
but the moment i tried to load into the first roblox game i wanted to play after it was fixed from the website, roblox stopped responding, task ended it because i was not about to wait 20 minutes for nothing/the game to load, and then i had a second roblox window not responding that i didn’t notice open (likely from the first unresponsive window) that i couldn’t close at ALL until i restarted my pc
at least i dunno if it’s not fixed again, i COULD try something since i noticed it while roblox was actually functioning, but it actually worked properly for a moment so next time it somehow fixes itself i am. going into a vip server first. progress though i think

? ok nvm same thing happened again except windows explorer + my desktop kept freaking out after i tried to play the same game in a vip server n i had to restart again. disabling stardock’s windows 11 blinds window skinning for roblox yesterday wasn’t the fix so. ermm idk